Skip to main content

Error generating artifacts for the following WSDL

Please note these forums are being decommissioned and use the new and improved forums at
1 reply [Last post]
Joined: 2012-11-29

I converted a stand-alone java application into a web service. The deploy on glassfish server is successful. When I test the webservice, I get the following error.

Error generating artifacts for the following WSDL http://localhost:8080/Dec/Dec?WSDL

Possible causes can be invoking https when the application is not configured for security

My java application has 3 classes.

@WebService(serviceName = "Dec")
public class Dec {
int num;
class Data{
public int []a;
public Data(int num) {
a= new int[num];
class T{
public double sum;


I tried to convert a java application with a single class to a web service and that worked perfectly.

Please help me with a way out of this issue.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Joined: 2005-01-14

Perhaps working with code that we know works, and then back-tracking to your classes to determine the problem, might help. I'd try blog article #3 and then #11 here: