Skip to main content

What have I done 'wrong'

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
3 replies [Last post]
vbkraemer
Offline
Joined: 2003-09-03

I am trying to create a stand-alone instance of a custom domain
(domain3) that has a portbase of 28000.

here is the transcript of actions that I thought would work...

bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
create-domain --portbase 28000 domain3
Enter admin user name [Enter to accept default "admin" / no password]>
Using port 28048 for Admin.
Using port 28080 for HTTP Instance.
Using port 28076 for JMS.
Using port 28037 for IIOP.
Using port 28081 for HTTP_SSL.
Using port 28038 for IIOP_SSL.
Using port 28039 for IIOP_MUTUALAUTH.
Using port 28086 for JMX_ADMIN.
Using port 28066 for OSGI_SHELL.
Using port 28009 for JAVA_DEBUGGER.
Distinguished Name of the self-signed X.509 Server Certificate is:
[CN=mjhmbl,OU=GlassFish,O=Oracle Corporation,L=Santa
Clara,ST=California,C=US]
Distinguished Name of the self-signed X.509 Server Certificate is:
[CN=mjhmbl-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
Clara,ST=California,C=US]
No domain initializers found, bypassing customization step
Domain domain3 created.
Domain domain3 admin port is 28048.
Domain domain3 allows admin login as user "admin" with no password.
Command create-domain executed successfully.
bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
start-domain domain3
Waiting for domain3 to start ........
Successfully started the domain : domain3
domain Location:
/export/home/vkraemer/GlassFish_Server_3.1.1/glassfish/domains/domain3
Log File:
/export/home/vkraemer/GlassFish_Server_3.1.1/glassfish/domains/domain3/logs/server.log
Admin Port: 28048
Command start-domain executed successfully.
bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
--port 28048 version
Version = GlassFish Server Open Source Edition 3.1.1-b06 (build 6)
Command version executed successfully.
bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
--port 28048 create-local-instance sai1
Failed to rendezvous with DAS on localhost:4848. Please check if this
server is running, that the host and port are correct, and that this
server is configured to allow remote access.
Command create-local-instance failed.

What did I do wrong?

Thanks,
vbk

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
tmueller
Offline
Joined: 2005-10-31

Did you already have at least one local instance created for domain1?

I suspect that what is happening is that create-local-instance is trying
to create instance "sai1" in the "localhost-domain1" node, and the
agent/config/das.properties file there says that the DAS is on port 4848
for that node.

Try adding "--node localhost-domain3" to your create-local-instance
command.

Tom

On 6/14/2011 1:37 PM, Vince Kraemer wrote:
> I am trying to create a stand-alone instance of a custom domain
> (domain3) that has a portbase of 28000.
>
> here is the transcript of actions that I thought would work...
>
> bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
> create-domain --portbase 28000 domain3
> Enter admin user name [Enter to accept default "admin" / no password]>
> Using port 28048 for Admin.
> Using port 28080 for HTTP Instance.
> Using port 28076 for JMS.
> Using port 28037 for IIOP.
> Using port 28081 for HTTP_SSL.
> Using port 28038 for IIOP_SSL.
> Using port 28039 for IIOP_MUTUALAUTH.
> Using port 28086 for JMX_ADMIN.
> Using port 28066 for OSGI_SHELL.
> Using port 28009 for JAVA_DEBUGGER.
> Distinguished Name of the self-signed X.509 Server Certificate is:
> [CN=mjhmbl,OU=GlassFish,O=Oracle Corporation,L=Santa
> Clara,ST=California,C=US]
> Distinguished Name of the self-signed X.509 Server Certificate is:
> [CN=mjhmbl-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
> Clara,ST=California,C=US]
> No domain initializers found, bypassing customization step
> Domain domain3 created.
> Domain domain3 admin port is 28048.
> Domain domain3 allows admin login as user "admin" with no password.
> Command create-domain executed successfully.
> bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
> start-domain domain3
> Waiting for domain3 to start ........
> Successfully started the domain : domain3
> domain Location:
> /export/home/vkraemer/GlassFish_Server_3.1.1/glassfish/domains/domain3
> Log File:
> /export/home/vkraemer/GlassFish_Server_3.1.1/glassfish/domains/domain3/logs/server.log
> Admin Port: 28048
> Command start-domain executed successfully.
> bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
> --port 28048 version
> Version = GlassFish Server Open Source Edition 3.1.1-b06 (build 6)
> Command version executed successfully.
> bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
> --port 28048 create-local-instance sai1
> Failed to rendezvous with DAS on localhost:4848. Please check if this
> server is running, that the host and port are correct, and that this
> server is configured to allow remote access.
> Command create-local-instance failed.
>
>
> What did I do wrong?
>
> Thanks,
> vbk
>

vbkraemer
Offline
Joined: 2003-09-03

Hi Tom,

Thanks for the suggestion. It seems to have worked.... but I am a bit
confused about why it works.

I am a bit confused about why we expect the user to specify the --node
option if they create multiple domains on a single host...

It seems like we are asking the user to enter data that we can
calculate... It seems like we 'know' that localhost is the 'first part'
of the node name. We can figure out that 'domain3' is the second part
of the node name, based on the port.

It seems like this is a usability problem... not a huge one... but still
a valid one.

vbk

Tom Mueller wrote:
> Did you already have at least one local instance created for domain1?
>
> I suspect that what is happening is that create-local-instance is
> trying to create instance "sai1" in the "localhost-domain1" node, and
> the agent/config/das.properties file there says that the DAS is on
> port 4848 for that node.
>
> Try adding "--node localhost-domain3" to your create-local-instance
> command.
>
> Tom
>
>
> On 6/14/2011 1:37 PM, Vince Kraemer wrote:
>> I am trying to create a stand-alone instance of a custom domain
>> (domain3) that has a portbase of 28000.
>>
>> here is the transcript of actions that I thought would work...
>>
>> bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
>> create-domain --portbase 28000 domain3
>> Enter admin user name [Enter to accept default "admin" / no password]>
>> Using port 28048 for Admin.
>> Using port 28080 for HTTP Instance.
>> Using port 28076 for JMS.
>> Using port 28037 for IIOP.
>> Using port 28081 for HTTP_SSL.
>> Using port 28038 for IIOP_SSL.
>> Using port 28039 for IIOP_MUTUALAUTH.
>> Using port 28086 for JMX_ADMIN.
>> Using port 28066 for OSGI_SHELL.
>> Using port 28009 for JAVA_DEBUGGER.
>> Distinguished Name of the self-signed X.509 Server Certificate is:
>> [CN=mjhmbl,OU=GlassFish,O=Oracle Corporation,L=Santa
>> Clara,ST=California,C=US]
>> Distinguished Name of the self-signed X.509 Server Certificate is:
>> [CN=mjhmbl-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
>> Clara,ST=California,C=US]
>> No domain initializers found, bypassing customization step
>> Domain domain3 created.
>> Domain domain3 admin port is 28048.
>> Domain domain3 allows admin login as user "admin" with no password.
>> Command create-domain executed successfully.
>> bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
>> start-domain domain3
>> Waiting for domain3 to start ........
>> Successfully started the domain : domain3
>> domain Location:
>> /export/home/vkraemer/GlassFish_Server_3.1.1/glassfish/domains/domain3
>> Log File:
>> /export/home/vkraemer/GlassFish_Server_3.1.1/glassfish/domains/domain3/logs/server.log
>>
>> Admin Port: 28048
>> Command start-domain executed successfully.
>> bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
>> --port 28048 version
>> Version = GlassFish Server Open Source Edition 3.1.1-b06 (build 6)
>> Command version executed successfully.
>> bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
>> --port 28048 create-local-instance sai1
>> Failed to rendezvous with DAS on localhost:4848. Please check if this
>> server is running, that the host and port are correct, and that this
>> server is configured to allow remote access.
>> Command create-local-instance failed.
>>
>>
>> What did I do wrong?
>>
>> Thanks,
>> vbk
>>

tmueller
Offline
Joined: 2005-10-31

Would you please file an issue on this?

The node name that is being used, "localhost-domain1" is chosen because
it is the only one in the nodes directory at the time you run the
command. The "localhost" and "name of domain" convention for naming the
first node is only used when the nodes directory is empty.

I expect that now that you have a second node and an instance there, if
you run the original command:

asadmin --port 28048 create-local-instance sai2

(but with a different instance name), it will fail, saying that there is
more than one node so that you have to select one.

Thanks.
Tom

On 6/14/2011 3:41 PM, Vince Kraemer wrote:
> Hi Tom,
>
> Thanks for the suggestion. It seems to have worked.... but I am a bit
> confused about why it works.
>
> I am a bit confused about why we expect the user to specify the --node
> option if they create multiple domains on a single host...
>
> It seems like we are asking the user to enter data that we can
> calculate... It seems like we 'know' that localhost is the 'first
> part' of the node name. We can figure out that 'domain3' is the
> second part of the node name, based on the port.
>
> It seems like this is a usability problem... not a huge one... but
> still a valid one.
>
> vbk
>
> Tom Mueller wrote:
>> Did you already have at least one local instance created for domain1?
>>
>> I suspect that what is happening is that create-local-instance is
>> trying to create instance "sai1" in the "localhost-domain1" node, and
>> the agent/config/das.properties file there says that the DAS is on
>> port 4848 for that node.
>>
>> Try adding "--node localhost-domain3" to your create-local-instance
>> command.
>>
>> Tom
>>
>>
>> On 6/14/2011 1:37 PM, Vince Kraemer wrote:
>>> I am trying to create a stand-alone instance of a custom domain
>>> (domain3) that has a portbase of 28000.
>>>
>>> here is the transcript of actions that I thought would work...
>>>
>>> bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
>>> create-domain --portbase 28000 domain3
>>> Enter admin user name [Enter to accept default "admin" / no password]>
>>> Using port 28048 for Admin.
>>> Using port 28080 for HTTP Instance.
>>> Using port 28076 for JMS.
>>> Using port 28037 for IIOP.
>>> Using port 28081 for HTTP_SSL.
>>> Using port 28038 for IIOP_SSL.
>>> Using port 28039 for IIOP_MUTUALAUTH.
>>> Using port 28086 for JMX_ADMIN.
>>> Using port 28066 for OSGI_SHELL.
>>> Using port 28009 for JAVA_DEBUGGER.
>>> Distinguished Name of the self-signed X.509 Server Certificate is:
>>> [CN=mjhmbl,OU=GlassFish,O=Oracle Corporation,L=Santa
>>> Clara,ST=California,C=US]
>>> Distinguished Name of the self-signed X.509 Server Certificate is:
>>> [CN=mjhmbl-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
>>> Clara,ST=California,C=US]
>>> No domain initializers found, bypassing customization step
>>> Domain domain3 created.
>>> Domain domain3 admin port is 28048.
>>> Domain domain3 allows admin login as user "admin" with no password.
>>> Command create-domain executed successfully.
>>> bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
>>> start-domain domain3
>>> Waiting for domain3 to start ........
>>> Successfully started the domain : domain3
>>> domain Location:
>>> /export/home/vkraemer/GlassFish_Server_3.1.1/glassfish/domains/domain3
>>> Log File:
>>> /export/home/vkraemer/GlassFish_Server_3.1.1/glassfish/domains/domain3/logs/server.log
>>>
>>> Admin Port: 28048
>>> Command start-domain executed successfully.
>>> bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
>>> --port 28048 version
>>> Version = GlassFish Server Open Source Edition 3.1.1-b06 (build 6)
>>> Command version executed successfully.
>>> bash-3.2$ /export/home/vkraemer/GlassFish_Server_3.1.1/bin/asadmin
>>> --port 28048 create-local-instance sai1
>>> Failed to rendezvous with DAS on localhost:4848. Please check if
>>> this server is running, that the host and port are correct, and that
>>> this server is configured to allow remote access.
>>> Command create-local-instance failed.
>>>
>>>
>>> What did I do wrong?
>>>
>>> Thanks,
>>> vbk
>>>
>