Skip to main content

webapp requiring a newer version of a module

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
No replies
arnaudq
Offline
Joined: 2006-08-24

I have a web app, running in glassfish v3.2, and which requires a more recent version of javamail (javamail 1.5).
What is the cleanest way to solve this dependency ?
Just stuffing the new mail.jar in the WEB-INF/lib directory of my webapp does not work. Nor does putting it in the lib/ext directory of the domain instance.

I resorted to replacing the existing javax.mail.jar file under glassfish/modules with the new version but that does not sound really clean.