Skip to main content

Variable (do_trace) has undefined value

Please note these forums are being decommissioned and use the new and improved forums at
No replies


I am running Glassfish (build 5) on our server. We have a Web Application on Glassfish which inserts values into an Informix database. In our office environment this works 100%. However on site this same setup does not work and returns the following error

java.sql.SQLException: Variable (do_trace) has undefined value. at com.informix.jdbc.IfxSqli.a( at com.informix.jdbc.IfxSqli.E( at com.informix.jdbc.IfxSqli.dispatchMsg( :2693) at com.informix.jdbc.IfxSqli.receiveMessage(IfxSqli.j ava:2609) at com.informix.jdbc.IfxSqli.executeCommand(IfxSqli.j ava:939) at com.informix.jdbc.IfxResultSet.b( :303) at com.informix.jdbc.IfxStatement.c( :1276) at com.informix.jdbc.IfxPreparedStatement.executeUpda te( at org.tollink.TrafficEvent.InsertTrafficEvent(Traffi at org.tollink.TrafficEvent.CreateTrafficEvent(Traffi at sun.reflect.GeneratedMethodAccessor88.invoke(Unkno wn Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(De at java.lang.reflect.Method.invoke( at org.glassfish.webservices.InstanceResolverImpl$1.i nvoke( at$2.invoke(Invoker at quest( at 61) at 0) at ) at 75) at ocess( at org.glassfish.webservices.MonitoringPipe.process(M at Request( at 61) at 0) at ) at 75) at ocess( at erSecurityPipe.processRequest(CommonServerSecurity at erSecurityPipe.process(CommonServerSecurityPipe.ja va:144) at Request( at 61) at 0) at ) at 75) at$2.process(WSE at$HttpTool kit.handle( at at er.handle( at org.glassfish.webservices.JAXWSServlet.doPost(JAXW at javax.servlet.http.HttpServlet.service(HttpServlet .java:688) at javax.servlet.http.HttpServlet.service(HttpServlet .java:770) at org.apache.catalina.core.StandardWrapper.service(S at org.apache.catalina.core.StandardWrapperValve.invo ke( at org.apache.catalina.core.StandardContextValve.invo ke( at org.apache.catalina.core.StandardPipeline.doInvoke ( at org.apache.catalina.core.StandardPipeline.invoke(S at org.apache.catalina.core.StandardHostValve.invoke( at org.apache.catalina.connector.CoyoteAdapter.doServ ice( at org.apache.catalina.connector.CoyoteAdapter.servic e( at r$ at r.service( at com.sun.grizzly.http.ProcessorTask.invokeAdapter(P at com.sun.grizzly.http.ProcessorTask.doProcess(Proce at com.sun.grizzly.http.ProcessorTask.process(Process at com.sun.grizzly.http.DefaultProtocolFilter.execute ( at com.sun.grizzly.DefaultProtocolChain.executeProtoc olFilter( at com.sun.grizzly.DefaultProtocolChain.execute(Defau at com.sun.grizzly.DefaultProtocolChain.execute(Defau at com.sun.grizzly.http.HttpProtocolChain.execute(Htt at com.sun.grizzly.ProtocolChainContextTask.doCall(Pr at at 1) at com.sun.grizzly.util.AbstractThreadPool$Worker.doW ork( at com.sun.grizzly.util.AbstractThreadPool$ ( at Caused by: java.sql.SQLException at com.informix.util.IfxErrMsg.getSQLException(IfxErr at com.informix.jdbc.IfxSqli.E(

I have tried to research this error but can not find much information on the problem and was hoping that someone on the forums could assist

I have tested the web service call through SOAPUI as well and get the same error on site but not in the test environment. The web service itself appears to be working fine, I have traced the XML packets in Wireshark, its just the insert into the database that appears to fail.

I also see this message in the glassfish log files : Unable to get ClientInfo for connection. Not sure if this is related and what the problem is

Any help greatly appreciated