Skip to main content

Starting the server with a jk-enabled listener logs SEVERE Error adding HttpProbes.

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
3 replies [Last post]
ejroberts
Offline
Joined: 2010-06-11

Running Glassfish 4.0 on JDK 1.7.0_13 on Windows 8

I added a jk listener through the admin console. Everything looks ok within the domain.xml, but whenever I start the server up I am getting this error

2013-07-17 11:58:13,384 SEVERE glassfish 4.0 javax.enterprise.web _ThreadID=13;_ThreadName=WrapperSimpleAppMain;_MessageID=AS-WEB-GLUE-00151; Error adding HttpProbes. NetworkListener http-listener-3s HttpCodecFilter is {1}

Is this a bug in Glassfish 4?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
ejroberts
Offline
Joined: 2010-06-11

Just in case the cause of the above is more easily spotted from the configuration, here are the config sections I have setup within the domain.xml

attachment of the listener to the virtual web server

<br />
        <virtual-server id="localhost" network-listeners="http-listener-1,http-listener-2,jk-listener" log-file="${com.sun.aas.instanceRoot}/log/server.log" access-log="${com.sun.aas.instanceRoot}/log" docroot="${com.sun.aas.instanceRoot}/docroot"></p>
<property name="default-web-xml" value="${com.sun.aas.instanceRoot}/config/default-web.xml"></property>
        </virtual-server><br />

definition of a supporting protocol

</p>
<protocol name="jk-listener">
            <http default-virtual-server="localhost" max-connections="250" xpowered-by="false"><br />
              <file-cache></file-cache><br />
            </http><br />
          </protocol>

definition of the network listener

<br />
          <network-listener port="8009" protocol="jk-listener" transport="tcp" name="jk-listener" thread-pool="ajp-thread-pool" jk-enabled="true"></network-listener><br />

definition of a separate thread pool

</p>
<thread-pool name="ajp-thread-pool" max-thread-pool-size="50" min-thread-pool-size="10" idle-thread-timeout-seconds="60"></thread-pool>

A separate Apache Httpd installation with reverse proxy configuration works fine, suggesting all is okay. The error on startup of Glassfish suggests otherwise.

Should any of the protocol settings in domain.xml be different for AJP ?

oleksiys
Offline
Joined: 2006-01-25

Please disregard this log message if it is related to JK listeners.

ejroberts
Offline
Joined: 2010-06-11

Thanks for the response.

Ok, so the message is not relevant for the jk-listener. Until that is detected in the code, then I will need to add a logging filter to remove the message from sight.

Unfortunately there appears to be a major bug in not being able to configure the logger settings from within the Admin GUI. Clicking on the logger settings of my local configuration results in a 500 error on the web server and the log entry "javax.el.PropertyNotFoundException: Target Unreachable, 'null' returned null
"

Once that is resolved, I will add further details to this entry in case anybody else needs to eradicate the log entry.