Skip to main content

Stand-by mode in GlassFish?

2 replies [Last post]
iroman
Offline
Joined: 2013-10-21
Points: 0

Hi, I am new here. I have the following problem.
I have GlassFish 4 on my V-Server. I have installed web application (JSF 2.2, Primefaces 4.0, Hibernate + Connection Pool ).
In Listner I changed port to 80 and /.
My application is available: www.mydomain.de. After the start I wait for 2 min. After that, everything runs fast.
after I have taken a 30 minute break i would call again www.mydomain.de but It takes again 2 minutes. After have being run fast recently.
Is there such a stand-by mode in GlassFish?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
f3riyanto
Offline
Joined: 2013-10-23
Points: 0

Hi Iroman,

As i now there no stand by mode in glassfish server.

Did you has been check and ensure your application not have heap space problem and database locking when application running.
Some issue are come from database and heap space.

Other issue may come from wrong glassfish configuration like connection pool resources or 3rd party/EIS server performance.

if you using a lot static files, then you can set glassfish cache to improve glassfish performance.

May this question can help to trace the root problem.

Thanks.
Ferry

.

iroman
Offline
Joined: 2013-10-21
Points: 0

Hi Ferry,
Thank you for your response.

You're right, it is probably due to my V-server performance.
he has only 1 GB RAM.
Application (Glassfish, Hibernate, PostgreSQL) running on my laptop with 2GB RAM without problem.
I use the -server JVM, -Xmx1024m and for JSF:

javax.faces.PROJECT_STAGE Production

Thank you very much.
Igor