Skip to main content

Re: Problem when intalled Glassfish application server on Ubuntu

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
6 replies [Last post]
alexismp
Offline
Joined: 2005-01-06

Salut,

I really see no other reason than an already occupied port for the domain to fail (jps -l should list any running jvm). A system reboot is a brutal but usually effective way to fix this. It would also be interesting to try creating a domain with the -portbase option to use a completely different set of ports and see if that helps.

The original poster should probably also make sure he uses a JDK and not just a JRE (but that will not fix the port issue).

-Alexis

Florent THOMAS wrote:

>Hy,
>
>I'm having almost the same issue on Centos6 except that I've checked :
>- Iptables are disabled
>- Selinux is disabled
>- No GF is running
>- No process is listening on the 4848 port
>
>And most of all, the create domain failed even on other port loke 4949,
>4747, etc...
>
>Thanks for your help
>
>Le 06/09/2011 08:34, Mihael Schmidt a écrit :
>> Hi,
>>
>> check if the port is in use:
>>
>> netstat -a -n | grep 4848
>>
>> check if another instance of glassfish is running
>>
>> ps -Af | grep glassfish
>>
>> Regards
>>
>> Mihael
>>
>>
>> Am 06.09.2011 01:51, schrieb :
>>>
>>>
>>>
>>> Hi all, i am instaling Glassfish application server, before old version
>>> runs well but now i removed and re-installed newest version. It appears
>>> problems.
>>> *Step by step*
>>> 1. I am using Linux 64
>>> 2. Java jdk 1.7
>>> /*dermfx@dermfx:~$ java -version*/
>>> /*java version "1.7.0"*/
>>> /*Java(TM) SE Runtime Environment (build 1.7.0-b147)*/
>>> /*Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)*/
>>> 3. I downloaded and run ./java_ee_sdk-6u3-unix-ml.sh
>>> 4. It appears errors
>>>
>>> /*PERFORMING THE REQUIRED CONFIGURATIONS*/
>>> /*______________________________________*/
>>> /*CREATING DOMAIN*/
>>> /*_______________*/
>>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin --user
>>> admin --passwordfile - create-domain --savelogin --checkports=false
>>> --adminport 4848 --instanceport 8080
>>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>>
>>> domain1*/
>>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin --user admin
>>> --passwordfile -
>>> create-domain --savelogin --checkports=false --adminport 4848
>>> --instanceport
>>> 8080
>>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>>
>>> domain1 Warning: You do not have permission to use port 4848 for domain1.
>>> Ignoring since the checkports option is set to false.*/
>>> /*Warning: You do not have permission to use port 8080 for domain1.
>>> Ignoring
>>> since the checkports option is set to false.*/
>>> /*Using port 4848 for Admin.*/
>>> /*Using port 8080 for HTTP Instance.*/
>>> /*Using port 7676 for JMS.*/
>>> /*Using port 3700 for IIOP.*/
>>> /*Using port 8181 for HTTP_SSL.*/
>>> /*Using port 3820 for IIOP_SSL.*/
>>> /*Using port 3920 for IIOP_MUTUALAUTH.*/
>>> /*Using port 8686 for JMX_ADMIN.*/
>>> /*Using default port 6666 for OSGI_SHELL.*/
>>> /*Using default port 9009 for JAVA_DEBUGGER.*/
>>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>>> /*[CN=dermfx,OU=GlassFish,O=Oracle Corporation,L=Santa
>>> Clara,ST=California,C=US]*/
>>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>>> /*[CN=dermfx-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
>>> Clara,ST=California,C=US]*/
>>> /*No domain initializers found, bypassing customization step*/
>>> /*Domain domain1 created.*/
>>> /*Domain domain1 admin port is 4848.*/
>>> /*Domain domain1 allows admin login as user "admin" with no password.*/
>>> /*Admin login information for host [localhost] and port [4848]*/
>>> /*is being overwritten with credentials provided because the*/
>>> /*--savelogin option was used during the create-domain command.*/
>>> /*Login information relevant to admin user name [admin]*/
>>> /*for this domain [domain1] stored at*/
>>> /*[/root/.asadminpass] successfully.*/
>>> /*Make sure that this file remains protected.*/
>>> /*Information stored in this file will be used by*/
>>> /*asadmin commands to manage this domain.*/
>>> /*Command create-domain executed successfully.*/
>>>
>>> /*STARTING DOMAIN*/
>>> /*_______________*/
>>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin
>>> start-domain domain1*/
>>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1*/
>>> /*There is a process already using the admin port 4848 -- it probably is
>>> another instance of a GlassFish server.*/
>>> /*Command start-domain failed.*/
>>>
>>> What happens with me ? Please help me.
>>> Thanks in advance,
>>> Diego
>>>
>>>
>>>
>>>
>>> --
>>>
>>> [Message sent by forum member 'diegothucao']
>>>
>>> View Post: http://forums.java.net/node/840291
>>>
>>>
>>

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Bernhard Thalma...
Offline
Joined: 2011-10-10

Salut Florent,

of course it's awfull ...it's analysis of system calls. It genereates lots
of information ... at least if you do not scope it well.

You may zip it and post it ... if it's not too much data.

-Bernhard

On Wed, Nov 30, 2011 at 11:31 AM, Florent THOMAS wrote:

> Hy,
>
> I used you command but it's awfull to analyze it. Should I post the result
> of the command?
>
> Regards
>
>
> Le 30/11/2011 11:26, Bernhard Thalmayr a écrit :
>
> In the end you can use 'strace' on 'asadmin' ... at least to find out
> where exactly it complains.
>
> -Bernhard
>
> On Wed, Nov 30, 2011 at 11:16 AM, Florent THOMAS wrote:
>
>> Hy,
>>
>> Thanks for answering,
>> Here is what I already tried :
>> - Reboot multiple times ==> no change
>> - ./asadmin create-domain --adminport 4949 domainDev ==> No success
>> - ./asadmin create-domain --adminport 4949 --checkports=false domainDev
>> ==> Success but impossible to run the glassfish
>>
>> I've installed jdk-6u29-linux-i586-rpm.bin with succes and if I
>> understand well, I must be a JDK.
>>
>> In the end, I tried your command :
>> *jps -l :
>> 1886 sun.tools.jps.Jps
>> *
>> but doesn't know how use it after
>>
>> Great thanks for answering so fast,
>>
>> Regards,
>>
>>
>> Le 30/11/2011 11:07, Alexis Moussine-Pouchkine a écrit :
>>
>> Salut,
>>
>> I really see no other reason than an already occupied port for the domain to fail (jps -l should list any running jvm). A system reboot is a brutal but usually effective way to fix this. It would also be interesting to try creating a domain with the -portbase option to use a completely different set of ports and see if that helps.
>>
>> The original poster should probably also make sure he uses a JDK and not just a JRE (but that will not fix the port issue).
>>
>> -Alexis
>>
>> Florent THOMAS wrote:
>>
>>
>> Hy,
>>
>> I'm having almost the same issue on Centos6 except that I've checked :
>> - Iptables are disabled
>> - Selinux is disabled
>> - No GF is running
>> - No process is listening on the 4848 port
>>
>> And most of all, the create domain failed even on other port loke 4949,
>> 4747, etc...
>>
>> Thanks for your help
>>
>> Le 06/09/2011 08:34, Mihael Schmidt a écrit :
>>
>> Hi,
>>
>> check if the port is in use:
>>
>> netstat -a -n | grep 4848
>>
>> check if another instance of glassfish is running
>>
>> ps -Af | grep glassfish
>>
>> Regards
>>
>> Mihael
>>
>>
>> Am 06.09.2011 01:51, schrieb :
>>
>> Hi all, i am instaling Glassfish application server, before old version
>> runs well but now i removed and re-installed newest version. It appears
>> problems.
>> *Step by step*
>> 1. I am using Linux 64
>> 2. Java jdk 1.7
>> /*dermfx@dermfx:~$ java -version*/
>> /*java version "1.7.0"*/
>> /*Java(TM) SE Runtime Environment (build 1.7.0-b147)*/
>> /*Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)*/
>> 3. I downloaded and run ./java_ee_sdk-6u3-unix-ml.sh
>> 4. It appears errors
>>
>> /*PERFORMING THE REQUIRED CONFIGURATIONS*/
>> /*______________________________________*/
>> /*CREATING DOMAIN*/
>> /*_______________*/
>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin --user
>> admin --passwordfile - create-domain --savelogin --checkports=false
>> --adminport 4848 --instanceport 8080
>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>
>> domain1*/
>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin --user admin
>> --passwordfile -
>> create-domain --savelogin --checkports=false --adminport 4848
>> --instanceport
>> 8080
>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>
>> domain1 Warning: You do not have permission to use port 4848 for domain1.
>> Ignoring since the checkports option is set to false.*/
>> /*Warning: You do not have permission to use port 8080 for domain1.
>> Ignoring
>> since the checkports option is set to false.*/
>> /*Using port 4848 for Admin.*/
>> /*Using port 8080 for HTTP Instance.*/
>> /*Using port 7676 for JMS.*/
>> /*Using port 3700 for IIOP.*/
>> /*Using port 8181 for HTTP_SSL.*/
>> /*Using port 3820 for IIOP_SSL.*/
>> /*Using port 3920 for IIOP_MUTUALAUTH.*/
>> /*Using port 8686 for JMX_ADMIN.*/
>> /*Using default port 6666 for OSGI_SHELL.*/
>> /*Using default port 9009 for JAVA_DEBUGGER.*/
>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>> /*[CN=dermfx,OU=GlassFish,O=Oracle Corporation,L=Santa
>> Clara,ST=California,C=US]*/
>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>> /*[CN=dermfx-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
>> Clara,ST=California,C=US]*/
>> /*No domain initializers found, bypassing customization step*/
>> /*Domain domain1 created.*/
>> /*Domain domain1 admin port is 4848.*/
>> /*Domain domain1 allows admin login as user "admin" with no password.*/
>> /*Admin login information for host [localhost] and port [4848]*/
>> /*is being overwritten with credentials provided because the*/
>> /*--savelogin option was used during the create-domain command.*/
>> /*Login information relevant to admin user name [admin]*/
>> /*for this domain [domain1] stored at*/
>> /*[/root/.asadminpass] successfully.*/
>> /*Make sure that this file remains protected.*/
>> /*Information stored in this file will be used by*/
>> /*asadmin commands to manage this domain.*/
>> /*Command create-domain executed successfully.*/
>>
>> /*STARTING DOMAIN*/
>> /*_______________*/
>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin
>> start-domain domain1*/
>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1*/
>> /*There is a process already using the admin port 4848 -- it probably is
>> another instance of a GlassFish server.*/
>> /*Command start-domain failed.*/
>>
>> What happens with me ? Please help me.
>> Thanks in advance,
>> Diego
>>
>>
>>
>>
>> --
>>
>> [Message sent by forum member 'diegothucao']
>>
>> View Post: http://forums.java.net/node/840291
>>
>>
>
>
> --
> IT-Consulting Bernhard Thalmayr
> - Painstaking Minds -
> 83620 Vagen (Munich area)
> Germany
>
>

--
IT-Consulting Bernhard Thalmayr
- Painstaking Minds -
83620 Vagen (Munich area)
Germany

flotho
Offline
Joined: 2009-08-25

Hy,

Thanks for answering,
Here is what I already tried :
- Reboot multiple times ==> no change
- ./asadmin create-domain --adminport 4949 domainDev ==> No success
- ./asadmin create-domain --adminport 4949 --checkports=false domainDev
==> Success but impossible to run the glassfish

I've installed jdk-6u29-linux-i586-rpm.bin with succes and if I
understand well, I must be a JDK.

In the end, I tried your command :
/jps -l :
1886 sun.tools.jps.Jps
/
but doesn't know how use it after

Great thanks for answering so fast,

Regards,

Le 30/11/2011 11:07, Alexis Moussine-Pouchkine a écrit :
> Salut,
>
> I really see no other reason than an already occupied port for the domain to fail (jps -l should list any running jvm). A system reboot is a brutal but usually effective way to fix this. It would also be interesting to try creating a domain with the -portbase option to use a completely different set of ports and see if that helps.
>
> The original poster should probably also make sure he uses a JDK and not just a JRE (but that will not fix the port issue).
>
> -Alexis
>
> Florent THOMAS wrote:
>
>> Hy,
>>
>> I'm having almost the same issue on Centos6 except that I've checked :
>> - Iptables are disabled
>> - Selinux is disabled
>> - No GF is running
>> - No process is listening on the 4848 port
>>
>> And most of all, the create domain failed even on other port loke 4949,
>> 4747, etc...
>>
>> Thanks for your help
>>
>> Le 06/09/2011 08:34, Mihael Schmidt a écrit :
>>> Hi,
>>>
>>> check if the port is in use:
>>>
>>> netstat -a -n | grep 4848
>>>
>>> check if another instance of glassfish is running
>>>
>>> ps -Af | grep glassfish
>>>
>>> Regards
>>>
>>> Mihael
>>>
>>>
>>> Am 06.09.2011 01:51, schrieb :
>>>>
>>>>
>>>> Hi all, i am instaling Glassfish application server, before old version
>>>> runs well but now i removed and re-installed newest version. It appears
>>>> problems.
>>>> *Step by step*
>>>> 1. I am using Linux 64
>>>> 2. Java jdk 1.7
>>>> /*dermfx@dermfx:~$ java -version*/
>>>> /*java version "1.7.0"*/
>>>> /*Java(TM) SE Runtime Environment (build 1.7.0-b147)*/
>>>> /*Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)*/
>>>> 3. I downloaded and run ./java_ee_sdk-6u3-unix-ml.sh
>>>> 4. It appears errors
>>>>
>>>> /*PERFORMING THE REQUIRED CONFIGURATIONS*/
>>>> /*______________________________________*/
>>>> /*CREATING DOMAIN*/
>>>> /*_______________*/
>>>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin --user
>>>> admin --passwordfile - create-domain --savelogin --checkports=false
>>>> --adminport 4848 --instanceport 8080
>>>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>>>
>>>> domain1*/
>>>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin --user admin
>>>> --passwordfile -
>>>> create-domain --savelogin --checkports=false --adminport 4848
>>>> --instanceport
>>>> 8080
>>>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>>>
>>>> domain1 Warning: You do not have permission to use port 4848 for domain1.
>>>> Ignoring since the checkports option is set to false.*/
>>>> /*Warning: You do not have permission to use port 8080 for domain1.
>>>> Ignoring
>>>> since the checkports option is set to false.*/
>>>> /*Using port 4848 for Admin.*/
>>>> /*Using port 8080 for HTTP Instance.*/
>>>> /*Using port 7676 for JMS.*/
>>>> /*Using port 3700 for IIOP.*/
>>>> /*Using port 8181 for HTTP_SSL.*/
>>>> /*Using port 3820 for IIOP_SSL.*/
>>>> /*Using port 3920 for IIOP_MUTUALAUTH.*/
>>>> /*Using port 8686 for JMX_ADMIN.*/
>>>> /*Using default port 6666 for OSGI_SHELL.*/
>>>> /*Using default port 9009 for JAVA_DEBUGGER.*/
>>>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>>>> /*[CN=dermfx,OU=GlassFish,O=Oracle Corporation,L=Santa
>>>> Clara,ST=California,C=US]*/
>>>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>>>> /*[CN=dermfx-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
>>>> Clara,ST=California,C=US]*/
>>>> /*No domain initializers found, bypassing customization step*/
>>>> /*Domain domain1 created.*/
>>>> /*Domain domain1 admin port is 4848.*/
>>>> /*Domain domain1 allows admin login as user "admin" with no password.*/
>>>> /*Admin login information for host [localhost] and port [4848]*/
>>>> /*is being overwritten with credentials provided because the*/
>>>> /*--savelogin option was used during the create-domain command.*/
>>>> /*Login information relevant to admin user name [admin]*/
>>>> /*for this domain [domain1] stored at*/
>>>> /*[/root/.asadminpass] successfully.*/
>>>> /*Make sure that this file remains protected.*/
>>>> /*Information stored in this file will be used by*/
>>>> /*asadmin commands to manage this domain.*/
>>>> /*Command create-domain executed successfully.*/
>>>>
>>>> /*STARTING DOMAIN*/
>>>> /*_______________*/
>>>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin
>>>> start-domain domain1*/
>>>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1*/
>>>> /*There is a process already using the admin port 4848 -- it probably is
>>>> another instance of a GlassFish server.*/
>>>> /*Command start-domain failed.*/
>>>>
>>>> What happens with me ? Please help me.
>>>> Thanks in advance,
>>>> Diego
>>>>
>>>>
>>>>
>>>>
>>>> --
>>>>
>>>> [Message sent by forum member 'diegothucao']
>>>>
>>>> View Post: http://forums.java.net/node/840291
>>>>
>>>>

alexismp
Offline
Joined: 2005-01-06

Try "asadmin create-domain --portbase …" (http://blogs.oracle.com/alexismp/entry/flexible_glassfish_domain_creatio...)
-Alexis

On 30 nov. 2011, at 11:16, Florent THOMAS wrote:

> Hy,
>
> Thanks for answering,
> Here is what I already tried :
> - Reboot multiple times ==> no change
> - ./asadmin create-domain --adminport 4949 domainDev ==> No success
> - ./asadmin create-domain --adminport 4949 --checkports=false domainDev ==> Success but impossible to run the glassfish
>
> I've installed jdk-6u29-linux-i586-rpm.bin with succes and if I understand well, I must be a JDK.
>
> In the end, I tried your command :
> jps -l :
> 1886 sun.tools.jps.Jps
>
> but doesn't know how use it after
>
> Great thanks for answering so fast,
>
> Regards,
>
>
> Le 30/11/2011 11:07, Alexis Moussine-Pouchkine a écrit :
>> Salut,
>>
>> I really see no other reason than an already occupied port for the domain to fail (jps -l should list any running jvm). A system reboot is a brutal but usually effective way to fix this. It would also be interesting to try creating a domain with the -portbase option to use a completely different set of ports and see if that helps.
>>
>> The original poster should probably also make sure he uses a JDK and not just a JRE (but that will not fix the port issue).
>>
>> -Alexis
>>
>> Florent THOMAS
>>
>> wrote:
>>
>>
>>> Hy,
>>>
>>> I'm having almost the same issue on Centos6 except that I've checked :
>>> - Iptables are disabled
>>> - Selinux is disabled
>>> - No GF is running
>>> - No process is listening on the 4848 port
>>>
>>> And most of all, the create domain failed even on other port loke 4949,
>>> 4747, etc...
>>>
>>> Thanks for your help
>>>
>>> Le 06/09/2011 08:34, Mihael Schmidt a écrit :
>>>
>>>> Hi,
>>>>
>>>> check if the port is in use:
>>>>
>>>> netstat -a -n | grep 4848
>>>>
>>>> check if another instance of glassfish is running
>>>>
>>>> ps -Af | grep glassfish
>>>>
>>>> Regards
>>>>
>>>> Mihael
>>>>
>>>>
>>>> Am 06.09.2011 01:51, schrieb
>>>> :
>>>>>
>>>>>
>>>>> Hi all, i am instaling Glassfish application server, before old version
>>>>> runs well but now i removed and re-installed newest version. It appears
>>>>> problems.
>>>>> *Step by step*
>>>>> 1. I am using Linux 64
>>>>> 2. Java jdk 1.7
>>>>> /*dermfx@dermfx:~$ java -version*/
>>>>> /*java version "1.7.0"*/
>>>>> /*Java(TM) SE Runtime Environment (build 1.7.0-b147)*/
>>>>> /*Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)*/
>>>>> 3. I downloaded and run ./java_ee_sdk-6u3-unix-ml.sh
>>>>> 4. It appears errors
>>>>>
>>>>> /*PERFORMING THE REQUIRED CONFIGURATIONS*/
>>>>> /*______________________________________*/
>>>>> /*CREATING DOMAIN*/
>>>>> /*_______________*/
>>>>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin --user
>>>>> admin --passwordfile - create-domain --savelogin --checkports=false
>>>>> --adminport 4848 --instanceport 8080
>>>>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>>>>
>>>>> domain1*/
>>>>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin --user admin
>>>>> --passwordfile -
>>>>> create-domain --savelogin --checkports=false --adminport 4848
>>>>> --instanceport
>>>>> 8080
>>>>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>>>>
>>>>> domain1 Warning: You do not have permission to use port 4848 for domain1.
>>>>> Ignoring since the checkports option is set to false.*/
>>>>> /*Warning: You do not have permission to use port 8080 for domain1.
>>>>> Ignoring
>>>>> since the checkports option is set to false.*/
>>>>> /*Using port 4848 for Admin.*/
>>>>> /*Using port 8080 for HTTP Instance.*/
>>>>> /*Using port 7676 for JMS.*/
>>>>> /*Using port 3700 for IIOP.*/
>>>>> /*Using port 8181 for HTTP_SSL.*/
>>>>> /*Using port 3820 for IIOP_SSL.*/
>>>>> /*Using port 3920 for IIOP_MUTUALAUTH.*/
>>>>> /*Using port 8686 for JMX_ADMIN.*/
>>>>> /*Using default port 6666 for OSGI_SHELL.*/
>>>>> /*Using default port 9009 for JAVA_DEBUGGER.*/
>>>>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>>>>> /*[CN=dermfx,OU=GlassFish,O=Oracle Corporation,L=Santa
>>>>> Clara,ST=California,C=US]*/
>>>>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>>>>> /*[CN=dermfx-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
>>>>> Clara,ST=California,C=US]*/
>>>>> /*No domain initializers found, bypassing customization step*/
>>>>> /*Domain domain1 created.*/
>>>>> /*Domain domain1 admin port is 4848.*/
>>>>> /*Domain domain1 allows admin login as user "admin" with no password.*/
>>>>> /*Admin login information for host [localhost] and port [4848]*/
>>>>> /*is being overwritten with credentials provided because the*/
>>>>> /*--savelogin option was used during the create-domain command.*/
>>>>> /*Login information relevant to admin user name [admin]*/
>>>>> /*for this domain [domain1] stored at*/
>>>>> /*[/root/.asadminpass] successfully.*/
>>>>> /*Make sure that this file remains protected.*/
>>>>> /*Information stored in this file will be used by*/
>>>>> /*asadmin commands to manage this domain.*/
>>>>> /*Command create-domain executed successfully.*/
>>>>>
>>>>> /*STARTING DOMAIN*/
>>>>> /*_______________*/
>>>>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin
>>>>> start-domain domain1*/
>>>>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1*/
>>>>> /*There is a process already using the admin port 4848 -- it probably is
>>>>> another instance of a GlassFish server.*/
>>>>> /*Command start-domain failed.*/
>>>>>
>>>>> What happens with me ? Please help me.
>>>>> Thanks in advance,
>>>>> Diego
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>>
>>>>> [Message sent by forum member 'diegothucao']
>>>>>
>>>>> View Post:
>>>>> http://forums.java.net/node/840291
>>>>>
>>>>>
>>>>>
>>>>>

flotho
Offline
Joined: 2009-08-25

@BERNARD : Here is the strace file attached

@Alexis : The following command
./asadmin create-domain --portbase 4700 domainDev

always return that the port is occupied whatever range I choose even if
netsat doesn't returns me the port as occupied

regards

Le 30/11/2011 11:44, Alexis Moussine-Pouchkine a écrit :
> Try "asadmin create-domain --portbase …" (http://blogs.oracle.com/alexismp/entry/flexible_glassfish_domain_creatio...)
> -Alexis
>
> On 30 nov. 2011, at 11:16, Florent THOMAS wrote:
>
>> Hy,
>>
>> Thanks for answering,
>> Here is what I already tried :
>> - Reboot multiple times ==> no change
>> - ./asadmin create-domain --adminport 4949 domainDev ==> No success
>> - ./asadmin create-domain --adminport 4949 --checkports=false domainDev ==> Success but impossible to run the glassfish
>>
>> I've installed jdk-6u29-linux-i586-rpm.bin with succes and if I understand well, I must be a JDK.
>>
>> In the end, I tried your command :
>> jps -l :
>> 1886 sun.tools.jps.Jps
>>
>> but doesn't know how use it after
>>
>> Great thanks for answering so fast,
>>
>> Regards,
>>
>>
>> Le 30/11/2011 11:07, Alexis Moussine-Pouchkine a écrit :
>>> Salut,
>>>
>>> I really see no other reason than an already occupied port for the domain to fail (jps -l should list any running jvm). A system reboot is a brutal but usually effective way to fix this. It would also be interesting to try creating a domain with the -portbase option to use a completely different set of ports and see if that helps.
>>>
>>> The original poster should probably also make sure he uses a JDK and not just a JRE (but that will not fix the port issue).
>>>
>>> -Alexis
>>>
>>> Florent THOMAS
>>>
>>> wrote:
>>>
>>>
>>>> Hy,
>>>>
>>>> I'm having almost the same issue on Centos6 except that I've checked :
>>>> - Iptables are disabled
>>>> - Selinux is disabled
>>>> - No GF is running
>>>> - No process is listening on the 4848 port
>>>>
>>>> And most of all, the create domain failed even on other port loke 4949,
>>>> 4747, etc...
>>>>
>>>> Thanks for your help
>>>>
>>>> Le 06/09/2011 08:34, Mihael Schmidt a écrit :
>>>>
>>>>> Hi,
>>>>>
>>>>> check if the port is in use:
>>>>>
>>>>> netstat -a -n | grep 4848
>>>>>
>>>>> check if another instance of glassfish is running
>>>>>
>>>>> ps -Af | grep glassfish
>>>>>
>>>>> Regards
>>>>>
>>>>> Mihael
>>>>>
>>>>>
>>>>> Am 06.09.2011 01:51, schrieb
>>>>> :
>>>>>>
>>>>>> Hi all, i am instaling Glassfish application server, before old version
>>>>>> runs well but now i removed and re-installed newest version. It appears
>>>>>> problems.
>>>>>> *Step by step*
>>>>>> 1. I am using Linux 64
>>>>>> 2. Java jdk 1.7
>>>>>> /*dermfx@dermfx:~$ java -version*/
>>>>>> /*java version "1.7.0"*/
>>>>>> /*Java(TM) SE Runtime Environment (build 1.7.0-b147)*/
>>>>>> /*Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)*/
>>>>>> 3. I downloaded and run ./java_ee_sdk-6u3-unix-ml.sh
>>>>>> 4. It appears errors
>>>>>>
>>>>>> /*PERFORMING THE REQUIRED CONFIGURATIONS*/
>>>>>> /*______________________________________*/
>>>>>> /*CREATING DOMAIN*/
>>>>>> /*_______________*/
>>>>>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin --user
>>>>>> admin --passwordfile - create-domain --savelogin --checkports=false
>>>>>> --adminport 4848 --instanceport 8080
>>>>>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>>>>>
>>>>>> domain1*/
>>>>>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin --user admin
>>>>>> --passwordfile -
>>>>>> create-domain --savelogin --checkports=false --adminport 4848
>>>>>> --instanceport
>>>>>> 8080
>>>>>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>>>>>
>>>>>> domain1 Warning: You do not have permission to use port 4848 for domain1.
>>>>>> Ignoring since the checkports option is set to false.*/
>>>>>> /*Warning: You do not have permission to use port 8080 for domain1.
>>>>>> Ignoring
>>>>>> since the checkports option is set to false.*/
>>>>>> /*Using port 4848 for Admin.*/
>>>>>> /*Using port 8080 for HTTP Instance.*/
>>>>>> /*Using port 7676 for JMS.*/
>>>>>> /*Using port 3700 for IIOP.*/
>>>>>> /*Using port 8181 for HTTP_SSL.*/
>>>>>> /*Using port 3820 for IIOP_SSL.*/
>>>>>> /*Using port 3920 for IIOP_MUTUALAUTH.*/
>>>>>> /*Using port 8686 for JMX_ADMIN.*/
>>>>>> /*Using default port 6666 for OSGI_SHELL.*/
>>>>>> /*Using default port 9009 for JAVA_DEBUGGER.*/
>>>>>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>>>>>> /*[CN=dermfx,OU=GlassFish,O=Oracle Corporation,L=Santa
>>>>>> Clara,ST=California,C=US]*/
>>>>>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>>>>>> /*[CN=dermfx-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
>>>>>> Clara,ST=California,C=US]*/
>>>>>> /*No domain initializers found, bypassing customization step*/
>>>>>> /*Domain domain1 created.*/
>>>>>> /*Domain domain1 admin port is 4848.*/
>>>>>> /*Domain domain1 allows admin login as user "admin" with no password.*/
>>>>>> /*Admin login information for host [localhost] and port [4848]*/
>>>>>> /*is being overwritten with credentials provided because the*/
>>>>>> /*--savelogin option was used during the create-domain command.*/
>>>>>> /*Login information relevant to admin user name [admin]*/
>>>>>> /*for this domain [domain1] stored at*/
>>>>>> /*[/root/.asadminpass] successfully.*/
>>>>>> /*Make sure that this file remains protected.*/
>>>>>> /*Information stored in this file will be used by*/
>>>>>> /*asadmin commands to manage this domain.*/
>>>>>> /*Command create-domain executed successfully.*/
>>>>>>
>>>>>> /*STARTING DOMAIN*/
>>>>>> /*_______________*/
>>>>>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin
>>>>>> start-domain domain1*/
>>>>>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1*/
>>>>>> /*There is a process already using the admin port 4848 -- it probably is
>>>>>> another instance of a GlassFish server.*/
>>>>>> /*Command start-domain failed.*/
>>>>>>
>>>>>> What happens with me ? Please help me.
>>>>>> Thanks in advance,
>>>>>> Diego
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>>
>>>>>> [Message sent by forum member 'diegothucao']
>>>>>>
>>>>>> View Post:
>>>>>> http://forums.java.net/node/840291
>>>>>>
>>>>>>
>>>>>>
>>>>>>

Marcelo Carvalh...
Offline
Joined: 2011-11-30

Hi,

I had this problem!

I solved the problem when I put the hostname in /etc/hosts.

exemplo:

$ hostname
ubuntu
$ cat /etc/hosts
...
::1 ubuntu localhost6.localdomain6 localhost6
127.0.1.1 ubuntu.ubuntu-domain ubuntu
...

Sincerely,

--

Marcelo Carvalho Fernandes Canhamero
CPqD - Diretoria de Tecnologia e Serviços
marceloc@cpqd.com.br
www.cpqd.com.br

2011/11/30 Florent THOMAS

> @BERNARD : Here is the strace file attached
>
> @Alexis : The following command
> ./asadmin create-domain --portbase 4700 domainDev
>
> always return that the port is occupied whatever range I choose even if
> netsat doesn't returns me the port as occupied
>
> regards
>
>
> Le 30/11/2011 11:44, Alexis Moussine-Pouchkine a écrit :
>
> Try "asadmin create-domain --portbase …" (http://blogs.oracle.com/alexismp/entry/flexible_glassfish_domain_creatio...)
> -Alexis
>
> On 30 nov. 2011, at 11:16, Florent THOMAS wrote:
>
>
> Hy,
>
> Thanks for answering,
> Here is what I already tried :
> - Reboot multiple times ==> no change
> - ./asadmin create-domain --adminport 4949 domainDev ==> No success
> - ./asadmin create-domain --adminport 4949 --checkports=false domainDev ==> Success but impossible to run the glassfish
>
> I've installed jdk-6u29-linux-i586-rpm.bin with succes and if I understand well, I must be a JDK.
>
> In the end, I tried your command :
> jps -l :
> 1886 sun.tools.jps.Jps
>
> but doesn't know how use it after
>
> Great thanks for answering so fast,
>
> Regards,
>
>
> Le 30/11/2011 11:07, Alexis Moussine-Pouchkine a écrit :
>
> Salut,
>
> I really see no other reason than an already occupied port for the domain to fail (jps -l should list any running jvm). A system reboot is a brutal but usually effective way to fix this. It would also be interesting to try creating a domain with the -portbase option to use a completely different set of ports and see if that helps.
>
> The original poster should probably also make sure he uses a JDK and not just a JRE (but that will not fix the port issue).
>
> -Alexis
>
> Florent THOMAS
> wrote:
>
>
>
> Hy,
>
> I'm having almost the same issue on Centos6 except that I've checked :
> - Iptables are disabled
> - Selinux is disabled
> - No GF is running
> - No process is listening on the 4848 port
>
> And most of all, the create domain failed even on other port loke 4949,
> 4747, etc...
>
> Thanks for your help
>
> Le 06/09/2011 08:34, Mihael Schmidt a écrit :
>
>
> Hi,
>
> check if the port is in use:
>
> netstat -a -n | grep 4848
>
> check if another instance of glassfish is running
>
> ps -Af | grep glassfish
>
> Regards
>
> Mihael
>
>
> Am 06.09.2011 01:51, schrieb :
>
> Hi all, i am instaling Glassfish application server, before old version
> runs well but now i removed and re-installed newest version. It appears
> problems.
> *Step by step*
> 1. I am using Linux 64
> 2. Java jdk 1.7
> /*dermfx@dermfx:~$ java -version*/
> /*java version "1.7.0"*/
> /*Java(TM) SE Runtime Environment (build 1.7.0-b147)*/
> /*Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)*/
> 3. I downloaded and run ./java_ee_sdk-6u3-unix-ml.sh
> 4. It appears errors
>
> /*PERFORMING THE REQUIRED CONFIGURATIONS*/
> /*______________________________________*/
> /*CREATING DOMAIN*/
> /*_______________*/
> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin --user
> admin --passwordfile - create-domain --savelogin --checkports=false
> --adminport 4848 --instanceport 8080
> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>
> domain1*/
> /*/home/dermfx/glassfish3/glassfish/bin/asadmin --user admin
> --passwordfile -
> create-domain --savelogin --checkports=false --adminport 4848
> --instanceport
> 8080
> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>
> domain1 Warning: You do not have permission to use port 4848 for domain1.
> Ignoring since the checkports option is set to false.*/
> /*Warning: You do not have permission to use port 8080 for domain1.
> Ignoring
> since the checkports option is set to false.*/
> /*Using port 4848 for Admin.*/
> /*Using port 8080 for HTTP Instance.*/
> /*Using port 7676 for JMS.*/
> /*Using port 3700 for IIOP.*/
> /*Using port 8181 for HTTP_SSL.*/
> /*Using port 3820 for IIOP_SSL.*/
> /*Using port 3920 for IIOP_MUTUALAUTH.*/
> /*Using port 8686 for JMX_ADMIN.*/
> /*Using default port 6666 for OSGI_SHELL.*/
> /*Using default port 9009 for JAVA_DEBUGGER.*/
> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
> /*[CN=dermfx,OU=GlassFish,O=Oracle Corporation,L=Santa
> Clara,ST=California,C=US]*/
> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
> /*[CN=dermfx-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
> Clara,ST=California,C=US]*/
> /*No domain initializers found, bypassing customization step*/
> /*Domain domain1 created.*/
> /*Domain domain1 admin port is 4848.*/
> /*Domain domain1 allows admin login as user "admin" with no password.*/
> /*Admin login information for host [localhost] and port [4848]*/
> /*is being overwritten with credentials provided because the*/
> /*--savelogin option was used during the create-domain command.*/
> /*Login information relevant to admin user name [admin]*/
> /*for this domain [domain1] stored at*/
> /*[/root/.asadminpass] successfully.*/
> /*Make sure that this file remains protected.*/
> /*Information stored in this file will be used by*/
> /*asadmin commands to manage this domain.*/
> /*Command create-domain executed successfully.*/
>
> /*STARTING DOMAIN*/
> /*_______________*/
> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin
> start-domain domain1*/
> /*/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1*/
> /*There is a process already using the admin port 4848 -- it probably is
> another instance of a GlassFish server.*/
> /*Command start-domain failed.*/
>
> What happens with me ? Please help me.
> Thanks in advance,
> Diego
>
>
>
>
> --
>
> [Message sent by forum member 'diegothucao']
>
> View Post: http://forums.java.net/node/840291
>
>
>
>

flotho
Offline
Joined: 2009-08-25

WONDERFULL!!!!!!!!!

Thank you, it also sove other little problems for me.

Regards

Le 30/11/2011 12:54, Marcelo Carvalho Fernandes Canhamero a écrit :
> Hi,
>
> I had this problem!
>
> I solved the problem when I put the hostnamein /etc/hosts.
>
> exemplo:
>
> $ hostname
> ubuntu
> $ cat /etc/hosts
> ...
> ::1 ubuntu localhost6.localdomain6 localhost6
> 127.0.1.1 ubuntu.ubuntu-domain ubuntu
> ...
>
> Sincerely,
>
> --
>
> Marcelo Carvalho Fernandes Canhamero
> CPqD - Diretoria de Tecnologia e Serviços
> marceloc@cpqd.com.br
> www.cpqd.com.br
>
> 2011/11/30 Florent THOMAS >
>
> @BERNARD : Here is the strace file attached
>
> @Alexis : The following command
> ./asadmin create-domain --portbase 4700 domainDev
>
> always return that the port is occupied whatever range I choose
> even if netsat doesn't returns me the port as occupied
>
> regards
>
>
> Le 30/11/2011 11:44, Alexis Moussine-Pouchkine a écrit :
>> Try "asadmin create-domain --portbase …" (http://blogs.oracle.com/alexismp/entry/flexible_glassfish_domain_creatio...)
>> -Alexis
>>
>> On 30 nov. 2011, at 11:16, Florent THOMAS wrote:
>>
>>> Hy,
>>>
>>> Thanks for answering,
>>> Here is what I already tried :
>>> - Reboot multiple times ==> no change
>>> - ./asadmin create-domain --adminport 4949 domainDev ==> No success
>>> - ./asadmin create-domain --adminport 4949 --checkports=false domainDev ==> Success but impossible to run the glassfish
>>>
>>> I've installed jdk-6u29-linux-i586-rpm.bin with succes and if I understand well, I must be a JDK.
>>>
>>> In the end, I tried your command :
>>> jps -l :
>>> 1886 sun.tools.jps.Jps
>>>
>>> but doesn't know how use it after
>>>
>>> Great thanks for answering so fast,
>>>
>>> Regards,
>>>
>>>
>>> Le 30/11/2011 11:07, Alexis Moussine-Pouchkine a écrit :
>>>> Salut,
>>>>
>>>> I really see no other reason than an already occupied port for the domain to fail (jps -l should list any running jvm). A system reboot is a brutal but usually effective way to fix this. It would also be interesting to try creating a domain with the -portbase option to use a completely different set of ports and see if that helps.
>>>>
>>>> The original poster should probably also make sure he uses a JDK and not just a JRE (but that will not fix the port issue).
>>>>
>>>> -Alexis
>>>>
>>>> Florent THOMAS
>>>>
>>>> wrote:
>>>>
>>>>
>>>>> Hy,
>>>>>
>>>>> I'm having almost the same issue on Centos6 except that I've checked :
>>>>> - Iptables are disabled
>>>>> - Selinux is disabled
>>>>> - No GF is running
>>>>> - No process is listening on the 4848 port
>>>>>
>>>>> And most of all, the create domain failed even on other port loke 4949,
>>>>> 4747, etc...
>>>>>
>>>>> Thanks for your help
>>>>>
>>>>> Le 06/09/2011 08:34, Mihael Schmidt a écrit :
>>>>>
>>>>>> Hi,
>>>>>>
>>>>>> check if the port is in use:
>>>>>>
>>>>>> netstat -a -n | grep 4848
>>>>>>
>>>>>> check if another instance of glassfish is running
>>>>>>
>>>>>> ps -Af | grep glassfish
>>>>>>
>>>>>> Regards
>>>>>>
>>>>>> Mihael
>>>>>>
>>>>>>
>>>>>> Am 06.09.2011 01:51, schrieb
>>>>>> :
>>>>>>> Hi all, i am instaling Glassfish application server, before old version
>>>>>>> runs well but now i removed and re-installed newest version. It appears
>>>>>>> problems.
>>>>>>> *Step by step*
>>>>>>> 1. I am using Linux 64
>>>>>>> 2. Java jdk 1.7
>>>>>>> /*dermfx@dermfx:~$ java -version*/
>>>>>>> /*java version "1.7.0"*/
>>>>>>> /*Java(TM) SE Runtime Environment (build 1.7.0-b147)*/
>>>>>>> /*Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)*/
>>>>>>> 3. I downloaded and run ./java_ee_sdk-6u3-unix-ml.sh
>>>>>>> 4. It appears errors
>>>>>>>
>>>>>>> /*PERFORMING THE REQUIRED CONFIGURATIONS*/
>>>>>>> /*______________________________________*/
>>>>>>> /*CREATING DOMAIN*/
>>>>>>> /*_______________*/
>>>>>>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin --user
>>>>>>> admin --passwordfile - create-domain --savelogin --checkports=false
>>>>>>> --adminport 4848 --instanceport 8080
>>>>>>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>>>>>>
>>>>>>> domain1*/
>>>>>>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin --user admin
>>>>>>> --passwordfile -
>>>>>>> create-domain --savelogin --checkports=false --adminport 4848
>>>>>>> --instanceport
>>>>>>> 8080
>>>>>>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>>>>>>
>>>>>>> domain1 Warning: You do not have permission to use port 4848 for domain1.
>>>>>>> Ignoring since the checkports option is set to false.*/
>>>>>>> /*Warning: You do not have permission to use port 8080 for domain1.
>>>>>>> Ignoring
>>>>>>> since the checkports option is set to false.*/
>>>>>>> /*Using port 4848 for Admin.*/
>>>>>>> /*Using port 8080 for HTTP Instance.*/
>>>>>>> /*Using port 7676 for JMS.*/
>>>>>>> /*Using port 3700 for IIOP.*/
>>>>>>> /*Using port 8181 for HTTP_SSL.*/
>>>>>>> /*Using port 3820 for IIOP_SSL.*/
>>>>>>> /*Using port 3920 for IIOP_MUTUALAUTH.*/
>>>>>>> /*Using port 8686 for JMX_ADMIN.*/
>>>>>>> /*Using default port 6666 for OSGI_SHELL.*/
>>>>>>> /*Using default port 9009 for JAVA_DEBUGGER.*/
>>>>>>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>>>>>>> /*[CN=dermfx,OU=GlassFish,O=Oracle Corporation,L=Santa
>>>>>>> Clara,ST=California,C=US]*/
>>>>>>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>>>>>>> /*[CN=dermfx-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
>>>>>>> Clara,ST=California,C=US]*/
>>>>>>> /*No domain initializers found, bypassing customization step*/
>>>>>>> /*Domain domain1 created.*/
>>>>>>> /*Domain domain1 admin port is 4848.*/
>>>>>>> /*Domain domain1 allows admin login as user "admin" with no password.*/
>>>>>>> /*Admin login information for host [localhost] and port [4848]*/
>>>>>>> /*is being overwritten with credentials provided because the*/
>>>>>>> /*--savelogin option was used during the create-domain command.*/
>>>>>>> /*Login information relevant to admin user name [admin]*/
>>>>>>> /*for this domain [domain1] stored at*/
>>>>>>> /*[/root/.asadminpass] successfully.*/
>>>>>>> /*Make sure that this file remains protected.*/
>>>>>>> /*Information stored in this file will be used by*/
>>>>>>> /*asadmin commands to manage this domain.*/
>>>>>>> /*Command create-domain executed successfully.*/
>>>>>>>
>>>>>>> /*STARTING DOMAIN*/
>>>>>>> /*_______________*/
>>>>>>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin
>>>>>>> start-domain domain1*/
>>>>>>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1*/
>>>>>>> /*There is a process already using the admin port 4848 -- it probably is
>>>>>>> another instance of a GlassFish server.*/
>>>>>>> /*Command start-domain failed.*/
>>>>>>>
>>>>>>> What happens with me ? Please help me.
>>>>>>> Thanks in advance,
>>>>>>> Diego
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> --
>>>>>>>
>>>>>>> [Message sent by forum member 'diegothucao']
>>>>>>>
>>>>>>> View Post:
>>>>>>> http://forums.java.net/node/840291
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>
>
>