Skip to main content

Re: GF 3.1 doesn't start after little updates

4 replies [Last post]
snjezana
Offline
Joined: 2005-02-15
Points: 0

What was the version of your initial 3.1 installation since it seems that your updates are coming from "dev" and not "stable" repository? Was it some promoted pre-FCS 3.1 build and not 3.1 FCS version?

If you don't want to perform wholesale update of your whole 3.1 installation to the latest 3.2 promoted build, you will need to explicitly install verifier packages of version 3.1. IMO, the easiest way to do that is to run these commands using pkg CLI client instead of GUI based updatetool:

pkg install
pkg install

And, if this was indeed promoted 3.1 build, and if you want to make sure that in the future you only get "stable" updates and not updates to promoted 3.2 builds, you will need to reconfigure installation to use stable repository as preferred update repository. To do that, you need to run:

pkg set-publisher -P -O http://pkg.glassfish.org/v3/stable stable.glassfish.org

HTH...

----- Original Message -----
From: mailinglist@tdeo.fr
To: users@glassfish.java.net
Sent: Monday, April 11, 2011 12:56:50 PM GMT -08:00 US/Canada Pacific
Subject: GF 3.1 doesn't start after little updates

Hy all of you,

I made a few upadtae :
- pkg tool kit and its brother
- glassfish verifier and its |10n companion

All the update process seems to work fine.
Unfortunately as I restarted GF I have this issue :

Launching GlassFish on Felix platform
Exception in thread "main" java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97)
at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55)
Caused by: com.sun.enterprise.module.ResolveError: Failed to start Bundle Id [292] State [INSTALLED] [org.glassfish.verifier(Verifier implementation module):3.2.0.b01]
at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:177)
at org.jvnet.hk2.osgiadapter.OSGiModuleImpl$2$1$1.loadClass(OSGiModuleImpl.java:344)
at com.sun.hk2.component.LazyInhabitant.loadClass(LazyInhabitant.java:124)
at com.sun.hk2.component.LazyInhabitant.fetch(LazyInhabitant.java:111)
at com.sun.hk2.component.EventPublishingInhabitant.get(EventPublishingInhabitant.java:135)
at com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:76)
at com.sun.enterprise.module.bootstrap.Main.findStartupService(Main.java:378)
at org.glassfish.kernel.GlassFishActivator$1.newGlassFish(GlassFishActivator.java:105)
at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:113)
... 6 more
Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.verifier [292]: Unable to resolve 292.0: missing requirement [292.0] package; (&(package=com.sun.appserv.connectors.internal.api)(version>=3.2.0))
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3443)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1727)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:922)
at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:169)
... 14 more

I uninstall the verifier and it tsrats fine. But now How can I do if I want the verifier whithout a problem?

Regards,

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
snjezana
Offline
Joined: 2005-02-15
Points: 0

Yes, that's definitely a bug - it should actually show you glassfish-verifier 3.1-43. If you start updatetool client and go to "Available addons" section you should see glassfish-verifier 3.1-43 in the default list. If this is not the case for you, please let me know...

Thanks,

Snjezana

----- Original Message -----
From: mailinglist@tdeo.fr
To: users@glassfish.java.net
Sent: Monday, April 11, 2011 2:30:27 PM GMT -08:00 US/Canada Pacific
Subject: Re: GF 3.1 doesn't start after little updates

I checked in the admin gui .
The available packages are the following :
glassfish-verifier Application Servers 3.2-1 1Mo dev.glassfish.org
glassfish-verifier-l10n Application Servers 3.1-41.1

Le 11/04/2011 23:07, Florent THOMAS a écrit :

Le 11/04/2011 22:35, Snjezana Sevo-Zenzerovic a écrit :

Please double check that your installation not only references stable.glassfish.org publisher repository but that it is also checked as preferred publisher...
The stable repo was declared and checked as preferred publisher

If that's really the case, do you remember if you were explicitly notified of an available update for pkg toolkit and if so, on which platform are you running? Also, how did you install glassfish-verifier packages? Client behavior for both pkg and updatetool clients should be such that it will always give priority to packages coming from preferred repository even if other repositories contain corresponding package of higher version. Did you by any chance install glassfish-verifier packages through Admin GUI in which case we may have a bug in Java based API that needs to be addressed...

I'm running on a mandriva with the latest JDK.
I installed the verifier with the admin gui in my browser.
I'm not sure my french level of english allows me to understand all of your questions.
Am I right?
Thanks,

Snjezana

----- Original Message -----
From: mai! linglist@tdeo.fr
To: snjezana.sevozenzerovic...
Sent: Monday, April 11, 2011 1:22:13 PM GMT -08:00 US/Canada Pacific
Subject: Re: GF 3.1 doesn't start after little updates

Hy,

Thanks for answering so fast.
I understand what you meant but my update tool is already focus on the http://pkg.glassfish.org/v3/stable package!
So I don't really understand why is it giving me something else than stable and 3.1 releases.

Thanks

Le 11/04/2011 22:13, Snjezana Sevo-Zenzerovic a écrit :

What was the version of your initial 3.1 installation since it seems that your updates are coming from "dev" and not "stable" repository? Was it some promoted pre-FCS 3.1 build and not 3.1 FCS version?

If you don't want to perform wholesale update of your whole 3.1 installation to the latest 3.2 promoted build, you will need to explicitly install verifier packages of version 3.1. IMO, the easiest way to do that is to run these commands using pkg CLI client instead of GUI based updatetool:

pkg install
pkg install

And, if this was indeed promoted 3.1 build, and if you want to make sure that in the future you only get "stable" updates and not updates to promoted 3.2 builds, you will need to reconfigure installation to use stable repository as preferred update ! repository. To do that, you need to run:

pkg set-publisher -P -O http://pkg.glassfish.org/v3/stable stable.glassfish.org

HTH...

----- Original Message -----
From: mailinglist@tdeo.fr
To: users@glassfish.java.net
Sent: Monday, April 11, 2011 12:56:50 PM GMT -08:00 US/Canada Pacific
Subject: GF 3.1 doesn't start after little updates

Hy all of you,

I made a few upadtae :
- pkg tool kit and its brother
- glassfish verifier and its |10n companion

All the update process seems to work fine.
Unfortunately as I restarted GF I have this issue :

Launching GlassFish on Felix platform
Exception in thread "main" java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97)
at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55)
Caused by: com.sun.enterprise.module.ResolveError: Failed to start Bundle Id [292] State [INSTALLED] [org.glassfish.verifier(Verifier implementation module):3.2.0.b01]
at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:177)
at org.jvnet.hk2.osgiadapter.OSGiModuleImpl$2$1$1.loadClass(OSGiModuleImpl.java:344)
at com.sun.hk2.component.LazyInhabitant.loadClass(LazyInhabitant.java:124)
at com.sun.hk2.component.LazyInhabitant.fetch(LazyInhabitant.java:111)
at com.sun.hk2.component.EventPublishingInhabitant.get(EventPublishingInhabitant.java:135)
at com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:76)
at com.sun.enterprise.module.bootstrap.Main.findStartupService(Main.java:378)
at org.glassfish.kernel.GlassFishActivator$1.newGlassFish(GlassFishActivator.java:105)
at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:113)
... 6 more
Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.verifier [292]: Unable to resolve 292.0: missing requirement [292.0] package; (&(package=com.sun.appserv.connectors.internal.api)(version>=3.2.0))
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3443)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1727)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:922)
at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:169)
... 14 more

I uninstall the verifier and it tsrats fine. But now How can I do if I want the verifier whithout a problem?

Regards,

snjezana
Offline
Joined: 2005-02-15
Points: 0

Please double check that your installation not only references stable.glassfish.org publisher repository but that it is also checked as preferred publisher...

If that's really the case, do you remember if you were explicitly notified of an available update for pkg toolkit and if so, on which platform are you running? Also, how did you install glassfish-verifier packages? Client behavior for both pkg and updatetool clients should be such that it will always give priority to packages coming from preferred repository even if other repositories contain corresponding package of higher version. Did you by any chance install glassfish-verifier packages through Admin GUI in which case we may have a bug in Java based API that needs to be addressed...

Thanks,

Snjezana

----- Original Message -----
From: mailinglist@tdeo.fr
To: snjezana.sevozenzerovic...
Sent: Monday, April 11, 2011 1:22:13 PM GMT -08:00 US/Canada Pacific
Subject: Re: GF 3.1 doesn't start after little updates

Hy,

Thanks for answering so fast.
I understand what you meant but my update tool is already focus on the http://pkg.glassfish.org/v3/stable package!
So I don't really understand why is it giving me something else than stable and 3.1 releases.

Thanks

Le 11/04/2011 22:13, Snjezana Sevo-Zenzerovic a écrit :

What was the version of your initial 3.1 installation since it seems that your updates are coming from "dev" and not "stable" repository? Was it some promoted pre-FCS 3.1 build and not 3.1 FCS version?

If you don't want to perform wholesale update of your whole 3.1 installation to the latest 3.2 promoted build, you will need to explicitly install verifier packages of version 3.1. IMO, the easiest way to do that is to run these commands using pkg CLI client instead of GUI based updatetool:

pkg install
pkg install

And, if this was indeed promoted 3.1 build, and if you want to make sure that in the future you only get "stable" updates and not updates to promoted 3.2 builds, you will need to reconfigure installation to use stable repository as preferred update ! repository. To do that, you need to run:

pkg set-publisher -P -O http://pkg.glassfish.org/v3/stable stable.glassfish.org

HTH...

----- Original Message -----
From: mailinglist@tdeo.fr
To: users@glassfish.java.net
Sent: Monday, April 11, 2011 12:56:50 PM GMT -08:00 US/Canada Pacific
Subject: GF 3.1 doesn't start after little updates

Hy all of you,

I made a few upadtae :
- pkg tool kit and its brother
- glassfish verifier and its |10n companion

All the update process seems to work fine.
Unfortunately as I restarted GF I have this issue :

Launching GlassFish on Felix platform
Exception in thread "main" java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97)
at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55)
Caused by: com.sun.enterprise.module.ResolveError: Failed to start Bundle Id [292] State [INSTALLED] [org.glassfish.verifier(Verifier implementation module):3.2.0.b01]
at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:177)
at org.jvnet.hk2.osgiadapter.OSGiModuleImpl$2$1$1.loadClass(OSGiModuleImpl.java:344)
at com.sun.hk2.component.LazyInhabitant.loadClass(LazyInhabitant.java:124)
at com.sun.hk2.component.LazyInhabitant.fetch(LazyInhabitant.java:111)
at com.sun.hk2.component.EventPublishingInhabitant.get(EventPublishingInhabitant.java:135)
at com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:76)
at com.sun.enterprise.module.bootstrap.Main.findStartupService(Main.java:378)
at org.glassfish.kernel.GlassFishActivator$1.newGlassFish(GlassFishActivator.java:105)
at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:113)
... 6 more
Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.verifier [292]: Unable to resolve 292.0: missing requirement [292.0] package; (&(package=com.sun.appserv.connectors.internal.api)(version>=3.2.0))
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3443)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1727)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:922)
at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:169)
... 14 more

I uninstall the verifier and it tsrats fine. But now How can I do if I want the verifier whithout a problem?

Regards,

snjezana
Offline
Joined: 2005-02-15
Points: 0

Just FYI - following Admin GUI issue has filed to track this:

http://java.net/jira/browse/GLASSFISH-16340

----- Original Message -----
From: snjezana.sevozenzerovic...
To: mailinglist@tdeo.fr
Cc: users@glassfish.java.net
Sent: Monday, April 11, 2011 2:34:52 PM GMT -08:00 US/Canada Pacific
Subject: Re: GF 3.1 doesn't start after little updates

Yes, that's definitely a bug - it should actually show you glassfish-verifier 3.1-43. If you start updatetool client and go to "Available addons" section you should see glassfish-verifier 3.1-43 in the default list. If this is not the case for you, please let me know...

Thanks,

Snjezana

----- Original Message -----
From: mailinglist@tdeo.fr
To: users@glassfish.java.net
Sent: Monday, April 11, 2011 2:30:27 PM GMT -08:00 US/Canada Pacific
Subject: Re: GF 3.1 doesn't start after little updates

I checked in the admin gui .
The available packages are the following :
glassfish-verifier Application Servers 3.2-1 1Mo dev.glassfish.org
glassfish-verifier-l10n Application Servers 3.1-41.1

Le 11/04/2011 23:07, Florent THOMAS a écrit :

Le 11/04/2011 22:35, Snjezana Sevo-Zenzerovic a écrit :

Please double check that your installation not only references stable.glassfish.org publisher repository but that it is also checked as preferred publisher...
The stable repo was declared and checked as preferred publisher

If that's really the case, do you remember if you were explicitly notified of an available update for pkg toolkit and if so, on which platform are you running? Also, how did you install glassfish-verifier packages? Client behavior for both pkg and updatetool clients should be such that it will always give priority to packages coming from preferred repository even if other repositories contain corresponding package of higher version. Did you by any chance install glassfish-verifier packages through Admin GUI in which case we may have a bug in Java based API that needs to be addressed...

I'm running on a mandriva with the latest JDK.
I installed the verifier with the admin gui in my browser.
I'm not sure my french level of english allows me to understand all of your questions.
Am I right?
Thanks,

Snjezana

----- Original Message -----
From: mai! linglist@tdeo.fr
To: snjezana.sevozenzerovic...
Sent: Monday, April 11, 2011 1:22:13 PM GMT -08:00 US/Canada Pacific
Subject: Re: GF 3.1 doesn't start after little updates

Hy,

Thanks for answering so fast.
I understand what you meant but my update tool is already focus on the http://pkg.glassfish.org/v3/stable package!
So I don't really understand why is it giving me something else than stable and 3.1 releases.

Thanks

Le 11/04/2011 22:13, Snjezana Sevo-Zenzerovic a écrit :

What was the version of your initial 3.1 installation since it seems that your updates are coming from "dev" and not "stable" repository? Was it some promoted pre-FCS 3.1 build and not 3.1 FCS version?

If you don't want to perform wholesale update of your whole 3.1 installation to the latest 3.2 promoted build, you will need to explicitly install verifier packages of version 3.1. IMO, the easiest way to do that is to run these commands using pkg CLI client instead of GUI based updatetool:

pkg install
pkg install

And, if this was indeed promoted 3.1 build, and if you want to make sure that in the future you only get "stable" updates and not updates to promoted 3.2 builds, you will need to reconfigure installation to use stable repository as preferred update ! repository. To do that, you need to run:

pkg set-publisher -P -O http://pkg.glassfish.org/v3/stable stable.glassfish.org

HTH...

----- Original Message -----
From: mailinglist@tdeo.fr
To: users@glassfish.java.net
Sent: Monday, April 11, 2011 12:56:50 PM GMT -08:00 US/Canada Pacific
Subject: GF 3.1 doesn't start after little updates

Hy all of you,

I made a few upadtae :
- pkg tool kit and its brother
- glassfish verifier and its |10n companion

All the update process seems to work fine.
Unfortunately as I restarted GF I have this issue :

Launching GlassFish on Felix platform
Exception in thread "main" java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:97)
at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:55)
Caused by: com.sun.enterprise.module.ResolveError: Failed to start Bundle Id [292] State [INSTALLED] [org.glassfish.verifier(Verifier implementation module):3.2.0.b01]
at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:177)
at org.jvnet.hk2.osgiadapter.OSGiModuleImpl$2$1$1.loadClass(OSGiModuleImpl.java:344)
at com.sun.hk2.component.LazyInhabitant.loadClass(LazyInhabitant.java:124)
at com.sun.hk2.component.LazyInhabitant.fetch(LazyInhabitant.java:111)
at com.sun.hk2.component.EventPublishingInhabitant.get(EventPublishingInhabitant.java:135)
at com.sun.hk2.component.AbstractInhabitantImpl.get(AbstractInhabitantImpl.java:76)
at com.sun.enterprise.module.bootstrap.Main.findStartupService(Main.java:378)
at org.glassfish.kernel.GlassFishActivator$1.newGlassFish(GlassFishActivator.java:105)
at com.sun.enterprise.glassfish.bootstrap.GlassFishMain$Launcher.launch(GlassFishMain.java:113)
... 6 more
Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.glassfish.verifier [292]: Unable to resolve 292.0: missing requirement [292.0] package; (&(package=com.sun.appserv.connectors.internal.api)(version>=3.2.0))
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3443)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1727)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:922)
at org.jvnet.hk2.osgiadapter.OSGiModuleImpl.start(OSGiModuleImpl.java:169)
... 14 more

I uninstall the verifier and it tsrats fine. But now How can I do if I want the verifier whithout a problem?

Regards,

snjezana
Offline
Joined: 2005-02-15
Points: 0

Thank you, I think I have enough information to troubleshoot the situation...

I did verify that no 3.2 content was published into Linux stable repository by mistake. Since you installed verifier packages using Admin GUI the problem seems to be limited to Update Center's Java API and I'll file an issue for that. My advice at this point would be to use either pkg or updatetool clients to install available updates and additional packages. If you do use Admin GUI, please make sure that you check the version of selected package - if it is set to "3.2", you probably need to install the package of the same name, but with version "3.1".

----- Original Message -----
From: mailinglist@tdeo.fr
To: snjezana.sevozenzerovic...
Sent: Monday, April 11, 2011 2:04:28 PM GMT -08:00 US/Canada Pacific
Subject: Re: GF 3.1 doesn't start after little updates

Le 11/04/2011 22:35, Snjezana Sevo-Zenzerovic a écrit :

Please double check that your installation not only references stable.glassfish.org publisher repository but that it is also checked as preferred publisher...
The stable repo was declared and checked as preferred publisher

If that's really the case, do you remember if you were explicitly notified of an available update for pkg toolkit and if so, on which platform are you running? Also, how did you install glassfish-verifier packages? Client behavior for both pkg and updatetool clients should be such that it will always give priority to packages coming from preferred repository even if other repositories contain corresponding package of higher version. Did you by any chance install glassfish-verifier packages through Admin GUI in which case we may have a bug in Java based API that needs to be addressed...

I'm running on a mandriva with the latest JDK.
I installed the verifier with the admin gui in my browser.
I'm not sure my french level of english allows me to understand all of your questions.
Am I right?

Thanks,

Snjezana