Skip to main content

Problem when intalled Glassfish application server on Ubuntu

5 replies [Last post]
diegothucao
Offline
Joined: 2011-09-05
Points: 0

Hi all, i am instaling Glassfish application server, before old version runs well but now i removed and re-installed newest version. It appears problems.
Step by step 1. I am using Linux 64
2. Java jdk 1.7

dermfx@dermfx:~$ java -version
java version "1.7.0"
Java(TM) SE Runtime Environment (build 1.7.0-b147)
Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)

3. I downloaded and run ./java_ee_sdk-6u3-unix-ml.sh
4. It appears errors

PERFORMING THE REQUIRED CONFIGURATIONS
______________________________________

CREATING DOMAIN
_______________
Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin --user admin --passwordfile - create-domain --savelogin --checkports=false --adminport 4848 --instanceport 8080 --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920 domain1
/home/dermfx/glassfish3/glassfish/bin/asadmin --user admin --passwordfile - create-domain --savelogin --checkports=false --adminport 4848 --instanceport 8080 --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920 domain1 Warning: You do not have permission to use port 4848 for domain1. Ignoring since the checkports option is set to false.
Warning: You do not have permission to use port 8080 for domain1. Ignoring since the checkports option is set to false.
Using port 4848 for Admin.
Using port 8080 for HTTP Instance.
Using port 7676 for JMS.
Using port 3700 for IIOP.
Using port 8181 for HTTP_SSL.
Using port 3820 for IIOP_SSL.
Using port 3920 for IIOP_MUTUALAUTH.
Using port 8686 for JMX_ADMIN.
Using default port 6666 for OSGI_SHELL.
Using default port 9009 for JAVA_DEBUGGER.
Distinguished Name of the self-signed X.509 Server Certificate is:
[CN=dermfx,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US]
Distinguished Name of the self-signed X.509 Server Certificate is:
[CN=dermfx-instance,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US]
No domain initializers found, bypassing customization step
Domain domain1 created.
Domain domain1 admin port is 4848.
Domain domain1 allows admin login as user "admin" with no password.
Admin login information for host [localhost] and port [4848]
is being overwritten with credentials provided because the
--savelogin option was used during the create-domain command.
Login information relevant to admin user name [admin]
for this domain [domain1] stored at
[/root/.asadminpass] successfully.
Make sure that this file remains protected.
Information stored in this file will be used by
asadmin commands to manage this domain.
Command create-domain executed successfully.

STARTING DOMAIN
_______________
Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1

/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1
There is a process already using the admin port 4848 -- it probably is another instance of a GlassFish server.
Command start-domain failed.

What happens with me ? Please help me.

Thanks in advance,
Diego

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Mihael Schmidt Guest
Offline
Joined: 2011-08-29
Points: 0

Hi,

check if the port is in use:

netstat -a -n | grep 4848

check if another instance of glassfish is running

ps -Af | grep glassfish

Regards

Mihael

Am 06.09.2011 01:51, schrieb :
>
>
>
> Hi all, i am instaling Glassfish application server, before old version
> runs well but now i removed and re-installed newest version. It appears
> problems.
> *Step by step*
> 1. I am using Linux 64
> 2. Java jdk 1.7
> /*dermfx@dermfx:~$ java -version*/
> /*java version "1.7.0"*/
> /*Java(TM) SE Runtime Environment (build 1.7.0-b147)*/
> /*Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)*/
> 3. I downloaded and run ./java_ee_sdk-6u3-unix-ml.sh
> 4. It appears errors
>
> /*PERFORMING THE REQUIRED CONFIGURATIONS*/
> /*______________________________________*/
> /*CREATING DOMAIN*/
> /*_______________*/
> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin --user
> admin --passwordfile - create-domain --savelogin --checkports=false
> --adminport 4848 --instanceport 8080
> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>
> domain1*/
> /*/home/dermfx/glassfish3/glassfish/bin/asadmin --user admin
> --passwordfile -
> create-domain --savelogin --checkports=false --adminport 4848
> --instanceport
> 8080
> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>
> domain1 Warning: You do not have permission to use port 4848 for domain1.
> Ignoring since the checkports option is set to false.*/
> /*Warning: You do not have permission to use port 8080 for domain1.
> Ignoring
> since the checkports option is set to false.*/
> /*Using port 4848 for Admin.*/
> /*Using port 8080 for HTTP Instance.*/
> /*Using port 7676 for JMS.*/
> /*Using port 3700 for IIOP.*/
> /*Using port 8181 for HTTP_SSL.*/
> /*Using port 3820 for IIOP_SSL.*/
> /*Using port 3920 for IIOP_MUTUALAUTH.*/
> /*Using port 8686 for JMX_ADMIN.*/
> /*Using default port 6666 for OSGI_SHELL.*/
> /*Using default port 9009 for JAVA_DEBUGGER.*/
> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
> /*[CN=dermfx,OU=GlassFish,O=Oracle Corporation,L=Santa
> Clara,ST=California,C=US]*/
> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
> /*[CN=dermfx-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
> Clara,ST=California,C=US]*/
> /*No domain initializers found, bypassing customization step*/
> /*Domain domain1 created.*/
> /*Domain domain1 admin port is 4848.*/
> /*Domain domain1 allows admin login as user "admin" with no password.*/
> /*Admin login information for host [localhost] and port [4848]*/
> /*is being overwritten with credentials provided because the*/
> /*--savelogin option was used during the create-domain command.*/
> /*Login information relevant to admin user name [admin]*/
> /*for this domain [domain1] stored at*/
> /*[/root/.asadminpass] successfully.*/
> /*Make sure that this file remains protected.*/
> /*Information stored in this file will be used by*/
> /*asadmin commands to manage this domain.*/
> /*Command create-domain executed successfully.*/
>
> /*STARTING DOMAIN*/
> /*_______________*/
> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin
> start-domain domain1*/
> /*/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1*/
> /*There is a process already using the admin port 4848 -- it probably is
> another instance of a GlassFish server.*/
> /*Command start-domain failed.*/
>
> What happens with me ? Please help me.
> Thanks in advance,
> Diego
>
>
>
>
> --
>
> [Message sent by forum member 'diegothucao']
>
> View Post: http://forums.java.net/node/840291
>
>

--
Mihael Schmidt
Software und System-Entwicklung
Schulz Gebäudeservice GmbH & Co. KG
Dr.-Max-Ilgner-Straße 17
32339 Espelkamp

Telefon: 05772-9100-00
Telefax: 05772-9100-11
Internet: www.sgbs.de

Persönlich haftende Gesellschafterin:
Gebäudereinigung Joachim Schulz
Verwaltungsgesellschaft mbH

Geschäftsführer: Joachim Schulz, Dirk Schulz, Norbert Kosica

Handelsregister Bad Oeynhausen:
HRA 5902, HRB 8591

flotho
Offline
Joined: 2009-08-25
Points: 0

Hy,

I Have exactly the same issue on centos6 and gf3.1.1 except that :
- selinux is disabled,
- iptables is disabled
- no process is listening on 4848
- the problem is the same on every ports

Thanks for your help

Regards

Le 06/09/2011 08:34, Mihael Schmidt a écrit :
> Hi,
>
> check if the port is in use:
>
> netstat -a -n | grep 4848
>
> check if another instance of glassfish is running
>
> ps -Af | grep glassfish
>
> Regards
>
> Mihael
>
>
> Am 06.09.2011 01:51, schrieb :
>>
>>
>>
>> Hi all, i am instaling Glassfish application server, before old version
>> runs well but now i removed and re-installed newest version. It appears
>> problems.
>> *Step by step*
>> 1. I am using Linux 64
>> 2. Java jdk 1.7
>> /*dermfx@dermfx:~$ java -version*/
>> /*java version "1.7.0"*/
>> /*Java(TM) SE Runtime Environment (build 1.7.0-b147)*/
>> /*Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)*/
>> 3. I downloaded and run ./java_ee_sdk-6u3-unix-ml.sh
>> 4. It appears errors
>>
>> /*PERFORMING THE REQUIRED CONFIGURATIONS*/
>> /*______________________________________*/
>> /*CREATING DOMAIN*/
>> /*_______________*/
>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin --user
>> admin --passwordfile - create-domain --savelogin --checkports=false
>> --adminport 4848 --instanceport 8080
>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>
>> domain1*/
>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin --user admin
>> --passwordfile -
>> create-domain --savelogin --checkports=false --adminport 4848
>> --instanceport
>> 8080
>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>
>> domain1 Warning: You do not have permission to use port 4848 for domain1.
>> Ignoring since the checkports option is set to false.*/
>> /*Warning: You do not have permission to use port 8080 for domain1.
>> Ignoring
>> since the checkports option is set to false.*/
>> /*Using port 4848 for Admin.*/
>> /*Using port 8080 for HTTP Instance.*/
>> /*Using port 7676 for JMS.*/
>> /*Using port 3700 for IIOP.*/
>> /*Using port 8181 for HTTP_SSL.*/
>> /*Using port 3820 for IIOP_SSL.*/
>> /*Using port 3920 for IIOP_MUTUALAUTH.*/
>> /*Using port 8686 for JMX_ADMIN.*/
>> /*Using default port 6666 for OSGI_SHELL.*/
>> /*Using default port 9009 for JAVA_DEBUGGER.*/
>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>> /*[CN=dermfx,OU=GlassFish,O=Oracle Corporation,L=Santa
>> Clara,ST=California,C=US]*/
>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>> /*[CN=dermfx-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
>> Clara,ST=California,C=US]*/
>> /*No domain initializers found, bypassing customization step*/
>> /*Domain domain1 created.*/
>> /*Domain domain1 admin port is 4848.*/
>> /*Domain domain1 allows admin login as user "admin" with no password.*/
>> /*Admin login information for host [localhost] and port [4848]*/
>> /*is being overwritten with credentials provided because the*/
>> /*--savelogin option was used during the create-domain command.*/
>> /*Login information relevant to admin user name [admin]*/
>> /*for this domain [domain1] stored at*/
>> /*[/root/.asadminpass] successfully.*/
>> /*Make sure that this file remains protected.*/
>> /*Information stored in this file will be used by*/
>> /*asadmin commands to manage this domain.*/
>> /*Command create-domain executed successfully.*/
>>
>> /*STARTING DOMAIN*/
>> /*_______________*/
>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin
>> start-domain domain1*/
>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1*/
>> /*There is a process already using the admin port 4848 -- it probably is
>> another instance of a GlassFish server.*/
>> /*Command start-domain failed.*/
>>
>> What happens with me ? Please help me.
>> Thanks in advance,
>> Diego
>>
>>
>>
>>
>> --
>>
>> [Message sent by forum member 'diegothucao']
>>
>> View Post: http://forums.java.net/node/840291
>>
>>
>

flotho
Offline
Joined: 2009-08-25
Points: 0

HY,

I Have almost the same problem on centos6 except :
- selinux is disabled,
- iptables is disabled
- no process is running or listening on 4848

The same problems appears on every ports I tried e.g : 4949, 4747, etc...

Thanks for your help

Le 06/09/2011 08:34, Mihael Schmidt a écrit :
> Hi,
>
> check if the port is in use:
>
> netstat -a -n | grep 4848
>
> check if another instance of glassfish is running
>
> ps -Af | grep glassfish
>
> Regards
>
> Mihael
>
>
> Am 06.09.2011 01:51, schrieb :
>>
>>
>>
>> Hi all, i am instaling Glassfish application server, before old version
>> runs well but now i removed and re-installed newest version. It appears
>> problems.
>> *Step by step*
>> 1. I am using Linux 64
>> 2. Java jdk 1.7
>> /*dermfx@dermfx:~$ java -version*/
>> /*java version "1.7.0"*/
>> /*Java(TM) SE Runtime Environment (build 1.7.0-b147)*/
>> /*Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)*/
>> 3. I downloaded and run ./java_ee_sdk-6u3-unix-ml.sh
>> 4. It appears errors
>>
>> /*PERFORMING THE REQUIRED CONFIGURATIONS*/
>> /*______________________________________*/
>> /*CREATING DOMAIN*/
>> /*_______________*/
>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin --user
>> admin --passwordfile - create-domain --savelogin --checkports=false
>> --adminport 4848 --instanceport 8080
>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>
>> domain1*/
>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin --user admin
>> --passwordfile -
>> create-domain --savelogin --checkports=false --adminport 4848
>> --instanceport
>> 8080
>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>
>> domain1 Warning: You do not have permission to use port 4848 for domain1.
>> Ignoring since the checkports option is set to false.*/
>> /*Warning: You do not have permission to use port 8080 for domain1.
>> Ignoring
>> since the checkports option is set to false.*/
>> /*Using port 4848 for Admin.*/
>> /*Using port 8080 for HTTP Instance.*/
>> /*Using port 7676 for JMS.*/
>> /*Using port 3700 for IIOP.*/
>> /*Using port 8181 for HTTP_SSL.*/
>> /*Using port 3820 for IIOP_SSL.*/
>> /*Using port 3920 for IIOP_MUTUALAUTH.*/
>> /*Using port 8686 for JMX_ADMIN.*/
>> /*Using default port 6666 for OSGI_SHELL.*/
>> /*Using default port 9009 for JAVA_DEBUGGER.*/
>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>> /*[CN=dermfx,OU=GlassFish,O=Oracle Corporation,L=Santa
>> Clara,ST=California,C=US]*/
>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>> /*[CN=dermfx-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
>> Clara,ST=California,C=US]*/
>> /*No domain initializers found, bypassing customization step*/
>> /*Domain domain1 created.*/
>> /*Domain domain1 admin port is 4848.*/
>> /*Domain domain1 allows admin login as user "admin" with no password.*/
>> /*Admin login information for host [localhost] and port [4848]*/
>> /*is being overwritten with credentials provided because the*/
>> /*--savelogin option was used during the create-domain command.*/
>> /*Login information relevant to admin user name [admin]*/
>> /*for this domain [domain1] stored at*/
>> /*[/root/.asadminpass] successfully.*/
>> /*Make sure that this file remains protected.*/
>> /*Information stored in this file will be used by*/
>> /*asadmin commands to manage this domain.*/
>> /*Command create-domain executed successfully.*/
>>
>> /*STARTING DOMAIN*/
>> /*_______________*/
>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin
>> start-domain domain1*/
>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1*/
>> /*There is a process already using the admin port 4848 -- it probably is
>> another instance of a GlassFish server.*/
>> /*Command start-domain failed.*/
>>
>> What happens with me ? Please help me.
>> Thanks in advance,
>> Diego
>>
>>
>>
>>
>> --
>>
>> [Message sent by forum member 'diegothucao']
>>
>> View Post: http://forums.java.net/node/840291
>>
>>
>

flotho
Offline
Joined: 2009-08-25
Points: 0

Hy,

I'm having almost the same issue on Centos6 except that I've checked :
- Iptables are disabled
- Selinux is disabled
- No GF is running
- No process is listening on the 4848 port

And most of all, the create domain failed even on other port loke 4949,
4747, etc...

Thanks for your help

Le 06/09/2011 08:34, Mihael Schmidt a écrit :
> Hi,
>
> check if the port is in use:
>
> netstat -a -n | grep 4848
>
> check if another instance of glassfish is running
>
> ps -Af | grep glassfish
>
> Regards
>
> Mihael
>
>
> Am 06.09.2011 01:51, schrieb :
>>
>>
>>
>> Hi all, i am instaling Glassfish application server, before old version
>> runs well but now i removed and re-installed newest version. It appears
>> problems.
>> *Step by step*
>> 1. I am using Linux 64
>> 2. Java jdk 1.7
>> /*dermfx@dermfx:~$ java -version*/
>> /*java version "1.7.0"*/
>> /*Java(TM) SE Runtime Environment (build 1.7.0-b147)*/
>> /*Java HotSpot(TM) 64-Bit Server VM (build 21.0-b17, mixed mode)*/
>> 3. I downloaded and run ./java_ee_sdk-6u3-unix-ml.sh
>> 4. It appears errors
>>
>> /*PERFORMING THE REQUIRED CONFIGURATIONS*/
>> /*______________________________________*/
>> /*CREATING DOMAIN*/
>> /*_______________*/
>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin --user
>> admin --passwordfile - create-domain --savelogin --checkports=false
>> --adminport 4848 --instanceport 8080
>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>
>> domain1*/
>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin --user admin
>> --passwordfile -
>> create-domain --savelogin --checkports=false --adminport 4848
>> --instanceport
>> 8080
>> --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
>>
>> domain1 Warning: You do not have permission to use port 4848 for domain1.
>> Ignoring since the checkports option is set to false.*/
>> /*Warning: You do not have permission to use port 8080 for domain1.
>> Ignoring
>> since the checkports option is set to false.*/
>> /*Using port 4848 for Admin.*/
>> /*Using port 8080 for HTTP Instance.*/
>> /*Using port 7676 for JMS.*/
>> /*Using port 3700 for IIOP.*/
>> /*Using port 8181 for HTTP_SSL.*/
>> /*Using port 3820 for IIOP_SSL.*/
>> /*Using port 3920 for IIOP_MUTUALAUTH.*/
>> /*Using port 8686 for JMX_ADMIN.*/
>> /*Using default port 6666 for OSGI_SHELL.*/
>> /*Using default port 9009 for JAVA_DEBUGGER.*/
>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>> /*[CN=dermfx,OU=GlassFish,O=Oracle Corporation,L=Santa
>> Clara,ST=California,C=US]*/
>> /*Distinguished Name of the self-signed X.509 Server Certificate is:*/
>> /*[CN=dermfx-instance,OU=GlassFish,O=Oracle Corporation,L=Santa
>> Clara,ST=California,C=US]*/
>> /*No domain initializers found, bypassing customization step*/
>> /*Domain domain1 created.*/
>> /*Domain domain1 admin port is 4848.*/
>> /*Domain domain1 allows admin login as user "admin" with no password.*/
>> /*Admin login information for host [localhost] and port [4848]*/
>> /*is being overwritten with credentials provided because the*/
>> /*--savelogin option was used during the create-domain command.*/
>> /*Login information relevant to admin user name [admin]*/
>> /*for this domain [domain1] stored at*/
>> /*[/root/.asadminpass] successfully.*/
>> /*Make sure that this file remains protected.*/
>> /*Information stored in this file will be used by*/
>> /*asadmin commands to manage this domain.*/
>> /*Command create-domain executed successfully.*/
>>
>> /*STARTING DOMAIN*/
>> /*_______________*/
>> /*Executing command :/home/dermfx/glassfish3/glassfish/bin/asadmin
>> start-domain domain1*/
>> /*/home/dermfx/glassfish3/glassfish/bin/asadmin start-domain domain1*/
>> /*There is a process already using the admin port 4848 -- it probably is
>> another instance of a GlassFish server.*/
>> /*Command start-domain failed.*/
>>
>> What happens with me ? Please help me.
>> Thanks in advance,
>> Diego
>>
>>
>>
>>
>> --
>>
>> [Message sent by forum member 'diegothucao']
>>
>> View Post: http://forums.java.net/node/840291
>>
>>
>

swchan2
Offline
Joined: 2005-03-29
Points: 0

There is another process occupied the port 4848.
You may like to stop or kill that process first.