Skip to main content

Problem with remote admin access

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
1 reply [Last post]
Micz84pl
Offline
Joined: 2013-11-14

Hi

I have a problem with glassfish4. I have runned it, I have set a password for admin user. when I access admin panel on port 4848 page displays and asks me to wait a moment to activate console. But it doeas nothing i have waitedfor several minutes but nothing happends. When i refresh a page server does not respond and i have to restert a domain.

What I am doing wrong?

Thank you
Michal

EDIT:
Ok i had expierd certificate. I have removed it from key store, but now server does not respond on 4848 port. There is no errors in server log. Server is runing properly, because it displays page on port 8080.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
rrugemalira
Offline
Joined: 2011-01-27

I've found out that the display page on port 8080 is from the web-browser cache. If you clear the history in the web-browser and run http://localhost:8080 you'll notice the server is not accessed.

To determine for sure whether the server is running or not I use /usr/local/glassfish-4.0/bin/asadmin start-domain domain1
and if my server is already running I'm informed to that effect.
If it is not running then it is started.

However, I have another problem I'm facing:
Netbeans requires the user ID: anonymous while asadmin start-domain domain requires user ID: admin

And this causes conflict when I run my application in netbeans.

Either the server is not accessed by netbeans and my application if I have started the server earlier using asadmin start-domain domain1

OR

When I try to start the server from Netbeans it won't start because of the conflict of user IDs.

So far I've failed to solve this problem and have posted in glassfish forum for help to no avail!

Let me know where you are at in solving your problem.