Skip to main content

problem deploying with asadmin

2 replies [Last post]
brianj12
Offline
Joined: 2011-06-20
Points: 0

Hi, I'm pretty new to glassfish. I managed to install a glassfish 3 server on my Linux box, and it seems to run fine. We've deployed some applications to it and those run fine too. What I'm trying to do though is do though is set up some automation so that we can do builds and always have the latest and greatest deployed to the server.

So I'm trying this:

asadmin undeploy myapp

asadmin deploy myapp.war

The undeploy works, the deploy doesn't, and I always get a message like:

"remote failure: File not found: <path>/myapp.war"

whether I run this command from the same directory that the war file is in and give it no path, or from another directory and give it a full path, or similar combinations, it always complains that it can't find the file, even though it does exist at the exact path given in the "file not found" error message, which is frustrating.

Any help would be appreciated.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
dmitry_kholodilov
Offline
Joined: 2013-01-24
Points: 0

This error occurs when Glassfish process doesn't have permissions to read WAR file. For example, when your Glassfish is started by "glassfish" user and myapp.war is located in "/home/brian" directory, which can only be accessed by "brian" and "root" users.

The solution - place WAR in some directory that could be accessed by "glassfish" user, e.g. /tmp. Of course, the WAR file also should have proper permissions settings (e.g. readable by all users - rw-r--r-- string in ls -l command output).

Hope this will be helpful.

h2mch
Offline
Joined: 2011-07-19
Points: 0

Have you found a solution? I have exactly the same problem