Skip to main content

loadbalancer iPlanet auto apply config

1 reply [Last post]
Anonymous

Hello friends,

To better explain the issue about applying the changes in the
loadbalancer.xml file in iPlanet Webserver, I¹ve attached a screenshot
showing the message appearing
on the screen (on the Web admin of iPlanet) when I create a loadbalancer
from the DAS and apply the changes, as with these commands :
(assuming 192.168.1.1 = LB iplanet and 192.168.1.2 = DAS glassfish, each of
the on a separate VM )

asadmin --host 192.168.1.2 --port 4848 --secure create-http-lb --devicehost
192.168.1.1 --deviceport 8082 --httpsrouting --target cluster1 cluster_lb
asadmin apply-http-lb-changes cluster_lb

The attachment is in french (sorry) but basically in a few words it is said
that the config file (loadbalancer.xml) has changed and I¹m asked whether I
want them apply or not.
first line : i dont want and the LB won¹t work
second line : I approve the changes and then it works.

What I would like is : skip this step and that the config auto applies
without warnings. (I¹ve tried to make a chmod 755 on the ³config² and
³config-store² folders on the LB but didn¹t change anything)
Everything is well set up with SSL (export of s1as is done etc...) (thanks
to jtclingan videos on youtube ;-) )
The link seems OK between LB (192.168.1.1) and the DAS (192.168.1.2) but...

Anything to see with the fact they are virtualized ? - I really don¹t think
-
(Œcause such a strange behavior also happens with my glassfish clusters on
SSH nodes when I want to check the health with ³asadamin validate-multicast²
: the instances don¹t see each others ..
although the ping or others network commands work fine ...)

Thanks in advance guys !
I need to solve these unknown issues.

--
Thomas CATTY
06.75.67.24.71

³There are three ways to get something done; do it yourself, hire someone,
or forbid your kids to do it.² (Mona Crane)

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Kshitiz Saxena Guest
Offline
Joined: 2011-04-05
Points: 0

Hi Thomas,

Please ignore the error you see in webserver admin console. The
apply-http-lb-changes command only impact the load-balancer xml in
instance config directory and not in admin server's config-store. Since
they are not in sync, you see that error message from webserver admin
console.

If apply-http-lb-changes goes fine, and load-balancing is working fine,
then ignore above error.

Thanks,
Kshitiz

On 12/11/12 9:16 PM, Thomas CATTY wrote:
> loadbalancer iPlanet auto apply config Hello friends,
>
> To better explain the issue about applying the changes in the
> loadbalancer.xml file in iPlanet Webserver, I've attached a screenshot
> showing the message appearing
> on the screen (on the Web admin of iPlanet) when I create a
> loadbalancer from the DAS and apply the changes, as with these
> commands :
> (assuming 192.168.1.1 = LB iplanet and 192.168.1.2 = DAS glassfish,
> each of the on a separate VM )
>
> asadmin --host 192.168.1.2 --port 4848 --secure create-http-lb
> --devicehost 192.168.1.1 --deviceport 8082 --httpsrouting --target
> cluster1 cluster_lb
> asadmin apply-http-lb-changes cluster_lb
>
> The attachment is in french (sorry) but basically in a few words it is
> said that the config file (loadbalancer.xml) has changed and I'm
> asked whether I want them apply or not.
> first line : i dont want and the LB won't work
> second line : I approve the changes and then it works.
>
> What I would like is : skip this step and that the config auto applies
> without warnings. (I've tried to make a chmod 755 on the "config" and
> "config-store" folders on the LB but didn't change anything)
> Everything is well set up with SSL (export of s1as is done etc...)
> (thanks to jtclingan videos on youtube ;-) )
> The link seems OK between LB (192.168.1.1) and the DAS (192.168.1.2)
> but...
>
> /Anything to see with the fact they are virtualized ? - I really don't
> think -
> ('cause such a strange behavior also happens with my glassfish
> clusters on SSH nodes when I want to check the health with "asadamin
> validate-multicast" : the instances don't see each others ..
> although the ping or others network commands work fine ...)
> /
> Thanks in advance guys !
> I need to solve these unknown issues.
>
> --
> Thomas CATTY
> 06.75.67.24.71
>
> "/There are three ways to get something done; do it yourself, hire
> someone,
> or forbid your kids to do it./" (/Mona Crane)
> /