Skip to main content

Latest 4.0.1-SNAPSHOT build from source fails to start

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
1 reply [Last post]
gcruscoe
Offline
Joined: 2003-06-30

Is anybody working on or know of the problem.

I have the latest code checked out from trunk. Everything builds with mvn install, but when I try to start it I get:

Exception in thread "main" java.lang.ExceptionInInitializerError
at com.sun.enterprise.glassfish.bootstrap.MainHelper.(MainHelper.java:65)
at com.sun.enterprise.glassfish.bootstrap.GlassFishMain.main(GlassFishMain.java:64)
at com.sun.enterprise.glassfish.bootstrap.ASMain.main(ASMain.java:54)
Caused by: java.util.MissingResourceException: Can't find com.sun.enterprise.glassfish.bootstrap.LogMessages bundle
at java.util.logging.Logger.setupResourceInfo(Logger.java:1942)
at java.util.logging.Logger.(Logger.java:380)
at java.util.logging.LogManager.demandLogger(LogManager.java:554)
at java.util.logging.Logger.demandLogger(Logger.java:455)
at java.util.logging.Logger.getLogger(Logger.java:553)
at com.sun.enterprise.glassfish.bootstrap.LogFacade.(LogFacade.java:60)
... 3 more

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
gcruscoe
Offline
Joined: 2003-06-30

After a clean install it works. Really glad that's all it was. It had taken several build attempts to get it built (took a long time to download all the dependencies). At some point I had to stop it and change locations to continue building -- it must have messed it up.

This allowed me to put together a "fix" for issue 21118.