Skip to main content

Installing Glassfish 3.1.1

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
3 replies [Last post]
davidvukovic
Offline
Joined: 2012-01-08

Trying to install a new installation of Glassfish 3.1.1 and got the following error message.

I have searched the web and these forums and could not find a solution.

Windows Server 2003 service pack 2.

Thoughts?

David

PERFORMING THE REQUIRED CONFIGURATIONS
______________________________________

CREATING DOMAIN
_______________
Executing command :C:\glassfish3\glassfish\bin\asadmin.bat --user admin --passwordfile - create-domain --savelogin --checkports=false --adminport 4848 --instanceport 8080 --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920 domain1
C:\glassfish3\glassfish\bin\asadmin.bat --user admin --passwordfile - create-domain --savelogin --checkports=false --adminport 4848 --instanceport 8080 --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920 domain1 Error: could not open `C:\glassfish3\jdk7\jre\lib\i386\jvm.cfg'

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
jimcpl
Offline
Joined: 2008-04-12

Hi,

That last line:

could not open `C:\glassfish3\jdk7\jre\lib\i386\jvm.cfg'

seems kind of odd.

It seems like it thinks your JDK is installed under the c:\glassfish3 directory?

When you ran the GF installer, did you have a JAVA_HOME environment variable set to point to your JDK directory?

Also, when I did the install, I had to use the "-j" parameter on the command line, pointing to the base of my JDK directory.

Jim

davidvukovic
Offline
Joined: 2012-01-08

Jim,

I did find that the path and JAVA_HOME enviroment variables were not set by jdk-7u2-windows-i586.exe installation program.

I added them to the system path but still got the could not open `C:\glassfish3\jdk7\jre\lib\i386\jvm.cfg' error.

I did find it under C:\Program Files\Java\jdk1.7.0_01\jre\lib\i386\jvm.cfg.

I noticed that there were more files under the jdk1.7.0_01 directory tree, so I renamed C:\glassfish3\jdk7 to C:\glassfish3\jdk7_old

and copied the full tree from C:\Program Files\Java\jdk1.7.0_01 to C:\glassfish3\ and renamed it C:\Program Files\jdk7

From there I re-ran the glassfish-3.1.1-windows.exe to completion.

Well that was after deleting domain1 a few times because the installation did not like having the previous partial setup of domain1 lying around.

Thanks for your help

David

jimcpl
Offline
Joined: 2008-04-12

davidvukovic wrote:

Jim,

I did find that the path and JAVA_HOME enviroment variables were not set by jdk-7u2-windows-i586.exe installation program.

I added them to the system path but still got the could not open `C:\glassfish3\jdk7\jre\lib\i386\jvm.cfg' error.

I did find it under C:\Program Files\Java\jdk1.7.0_01\jre\lib\i386\jvm.cfg.

I noticed that there were more files under the jdk1.7.0_01 directory tree, so I renamed C:\glassfish3\jdk7 to C:\glassfish3\jdk7_old

and copied the full tree from C:\Program Files\Java\jdk1.7.0_01 to C:\glassfish3\ and renamed it C:\Program Files\jdk7

From there I re-ran the glassfish-3.1.1-windows.exe to completion.

Well that was after deleting domain1 a few times because the installation did not like having the previous partial setup of domain1 lying around.

Thanks for your help

David

Hi,

I'm glad you got it working, but it still seems kind of odd that the JDK directory would appear under the glassfish directory...

Jim