Skip to main content

How to disable ssl/https on Glassfish 3

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
No replies
michaelbb
Offline
Joined: 2013-12-17

Hi,

I have been asked to fix an invalid ssl sertificate for a customer, and the prefered solution is to just remove ssl/https since this is a file upload server that does not need this kind of security.

Since the guy who set this up is on a sick leave I have no clues on how this has been set up, and I am totally new to Glassfish. All he has told me is that there should not be any redirect from http to https, so just disabling the http-listener2 in Glassfish and give the new (http) URL to the customer should be sufficient.

Disabling ssl/https should not really be any problem, but for some reason I get redirected from http to https when I try to access the page using only http.

Whatever I do that disables or invalidates the ssl connection will just result in 404, missing security sertificate or other errors related to the secure connection. I have tried to disable http-listener-2, disabling security for http-listener-2 and removed the security sertificate. The result is as if I was trying to access the now disabled https URL.

I noticed that Apache and Glassfish are both running on the server, so I´ve looked at Apache config files but could not find anything that would redirect to https.

I have modified web.inf for the application and changed this line:

CONFIDENTIAL to NONE

...which is the only thing I´ve found that could cause this kind of redirect, but that did not change anything. Removing the whole element does not work, the application will not reload.

Any ideas why I am being redirected from http to https and how to fix this?