Skip to main content

How to disable authentication for glassfish server?

Please note these forums are being decommissioned and use the new and improved forums at
No replies
Joined: 2013-11-06

Hi expert,

I have a web application deployed on glassfish server And I have a client which connects to the web application. The client will authenticate with server with digest authentication (challenge\response). We use the default authentication in glassfish server and the authentication is done by glassfish server. And it works fine.

However, I want to run a performance testing to replay all client requests including the requests for authentication. Since it's challenge/response authentication mechanism, the original requests can not pass authentication and glassfish server replies 401. I want to know is there any way to disable glassfish authentication so that the authentication passes when I replay my original request?

Thanks very much!