Skip to main content

HELP me please .glassfish 3.1.2 .CAll EJB remote not possible . App client with webstart dont work ouside the LAN .

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
No replies
mauro2011
Offline
Joined: 2011-06-08

I write for problem that I can not fix .
is not possible that any person is capable to make work .

I have googled but but i have not found any solution for remote call at ejb deployed into glassfish3.1.2 and appclient with javawebstart.
I have tried the appclient from ACC with javawebstart.
It work from pc into my LAN.

But not work ouside the LAN .
i have deployed the enterprise project into glassfsih 3.1.2 .

my iiop listener is 192.169.1.212
i have tried to change it at my the public ip , but next glassfish dont start .

i have realized that the iiop listener return ALWAYS the privat ip of glassfish , that for me is 192.168.1.212 .
there is no way to return the public address.

I have set also into the VM options of glassfish the properties:

like into the documentation at :
documentation for java-clients for glassfsih3.1.2

these settings would be responsible for translating calls to remote methods from public to private address indirzzo.
-Dcom.sun.corba.ee.ORBVAAHost=public-IP-adress
-Dcom.sun.corba.ee.ORBVAAPort=public-port
-Dcom.sun.corba.ee.ORBUserConfigurators.com.sun.corba.ee.impl.plugin.hwlb.VirtualAddressAgentImpl=x

but not work!!!!!!!!!!!!!
I not have resolved any way.

i have
is not possible to start the Glassfish server is javaee6 reference not allowed to be called remotely from a PC outside the LAN.
For the engineers at Oracle would be the case of remedy.!!
--------------------------------------------------------------------
READ THE FOLLOWING FROM THE document :App client cannot find EJB behind NAT (17147) and EJB remote deployed on GF behind a NAT inaccessible (17151).

App client cannot find EJB behind NAT (17147) and EJB remote deployed on GF behind a NAT inaccessible (17151)
Description

The IIOP protocol as implemented in GlassFish Server calls the ORB to locate the EJB component. Because the EJB component is deployed on the same server as the ORB, the ORB sends the private IP address to the client instead of the public IP address. The ORB has no way of knowing the public IP address, which is determined by the firewall. The client then tries to connect using the private IP address, which does not go though the firewall.
Workaround

None. There is no properly tested workaround available for this issue.
-------------------------------------

Please help me
tank you mauro

AttachmentSize
VM-OPTIONS.jpg282.39 KB