Skip to main content

Having trouble setting up SSL Certificates

2 replies [Last post]
bcarlis
Offline
Joined: 2013-10-17
Points: 0

Can someone help me?

I have attempt to load certificates using JavaDude link
http://javadude.wordpress.com/2010/04/06/getting-started-with-glassfish-...

I've attached the files showing the process I did :
1 GlassFish_APEX NotesPublic.txt

then I was given the following link from Comodo:
https://support.comodo.com/index.php?_m=knowledgebase&_a=viewarticle&kba...

Got new certificates, deleted all entries and tried again
CreateCSRforComodoPublic.txt was to recreate the certificates
2 Process Followed Public.txt

Any help would be desired.

I am new to this certificate thing.. but I noticed the Create keystore name is not what was used throughout the last certificate loading.
Do these need to be the same?

Thank you Bill

AttachmentSize
1_GlassFish_APEX_NotesPublic.txt5.71 KB
CreateCSRforComodoPublic.txt3 KB
2_Process_Followed_Public.txt16.04 KB

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
yatinkv
Offline
Joined: 2013-10-27
Points: 0

Dear Bill,

I'm getting the same issue and not able to apply the comodo * certificates on my glassfish server also. Please let me know if you have managed to solve the issue.

With Regards
Yatin

bcarlis
Offline
Joined: 2013-10-17
Points: 0

SOLVED:

1. Installed the free Glassfish 4.0 (to start fresh)

2. Created new domain

3. Tested at this stage
http://localhost:8080/ - got as it should
GlassFish Server - Your server is now running

https://localhost:8181/ - got as it should
The site's security certificate is not trusted!
clicked through and got as it should
GlassFish Server - Your server is now running

4. Deployed APEX

5. Tested at this stage
http://localhost:8080/apex - got the APEX login
https://localhost:8181/ - got as it should
The site's security certificate is not trusted!
clicked through and got as it should the APEX login

6. Moved my keystore that Comodo helped me create to the new install.

7. Tested
https://localhost:8181/ - got generic error
Couldn't figure it out.

8. Contacted Comodo and they recreated my error and told me to do the following:
Modified 'domain.xml' manually.
1. Changed 'keystore.jks' to 'ourname.keystore' in the section that contains...
java-config debug-options="-agentlib:jdwp=transport=dt_socket,server=y,suspend=n,address=9009" system-classpath="" classpath-suffix=""

2. In addition to if you're keystore's password is not the default of 'changeit',
you will need to add the following as a JVM option
-Djavax.net.ssl.keyStorePassword=MY_KEYSTORE_PASS

right after the line containing
-Djavax.net.ssl.keyStore=..."

3. Restarted glassfish and the application should work.

My did! WooHoo!