Skip to main content

glassfish4 - dcom node - run glassfish as specific user

Please note these forums are being decommissioned and use the new and improved forums at
3 replies [Last post]
Joined: 2011-08-25

I have a cluster running on Windows 2008 with 2 nodes: 1 CONFIG and 1 DCOM. The DCOM node is working and validate-dcom is successful. However, even though I have the username set to apps_admin in the dcom node configuration, I see that the instance started on the node is not run under that user. Looking at the system property I see computername$.

This is only the case when I run start-instance from the DAS. When i start the instance as a windows services on the local machine, the is correct (same as the user configured in the windows service run-as).

So my question is: How can I configure what Windows user runs the instances on remote DCOM nodes when starting the node with asadmin commands (instead of as a local windows service)?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Joined: 2014-08-06

bradvido wrote:
... The DCOM node is working and validate-dcom is successful....

Hi, Could you please share the steps you took to setup the DCOM node?

For about a week now, I have been trying to setup two DCOM instances - one on each Windows 2008 machines - while the DAS is on another Windows 7 machine.
The following link had the closest guidance but I still get the ".. is UAC on? : Logon failure: Access denied."

Thank you.

Sorry I do not have any solution to your original question.

Joined: 2011-08-25

The important thing i found is the reg keys...
Modify reg keys to allow the [user / groups that glassfish is running as] full access (Also see setup-local-dcom asadmin cmd).


Joined: 2014-08-06

(apologies if my question causes a digression to your original thread).

Yes. My steps included getting access to the keys and usage of the setup-local-dcom cmd.

My steps were gleaned from the GF4 ha-admin guide and few other Byron Nevin's blogs on Clustering with DCOM.
1. On Remote machine -
* started asadmin for a basic Glassfish 4 installation.
* ran setup-local-dcom

2. On machine with DAS
* Ensured DAS is up
* setup a password alias
* validate-dcom to remote host with password file.

This throws the error that is on:

Tried the suggestions on this article. But same error persists.

".... If validate-local-dcom fails then see another blog that describes further configuration steps you may need to make on the Windows node...."
The 'another blog' goes to Oracle home page.

Not sure what to check next.