Skip to main content

glassfish idle thread timeout

1 reply [Last post]
Matěj Plch Guest
Offline
Joined: 2011-04-17
Points: 0

We have REST service which takes more than 15min. WE have configured
thread pool timeout, set timeout throught console, but its not working.
I found quite a lot of posts on this topic, in summer 2010 the
developers wrote, that they know about it and it will be fixed in the
next release, but I have *GlassFish Server Open Source Edition*3.1
(build 43) *and it***is not working.
Was it fixed or not? How to set timeout?

My domain.xml:

That error:
WARNING: GRIZZLY0023: Interrupting idle Thread: http-thread-pool-1-8080(1).
SEVERE: java.lang.InterruptedException: sleep interrupted

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
oleksiys
Offline
Joined: 2006-01-25
Points: 0

Hi Matej,

please increase the HTTP request processing timeout (default value is
15mins) by setting

asadmin set
server-config.network-config.protocols.protocol.http-listener-1.http.request-timeout-seconds=NNN

where NNN the max number of *seconds* one single request might be
processing by a thread.
As I told the default value is 15mins, which means NNN=900, so you can
set any higher value.

Hope this will help.

WBR,
Alexey.

On 04/14/2011 02:09 PM, Matěj Plch wrote:
> We have REST service which takes more than 15min. WE have configured
> thread pool timeout, set timeout throught console, but its not
> working. I found quite a lot of posts on this topic, in summer 2010
> the developers wrote, that they know about it and it will be fixed in
> the next release, but I have *GlassFish Server Open Source Edition*3.1
> (build 43) *and it***is not working.
> Was it fixed or not? How to set timeout?
>
> My domain.xml:
>
> transport="tcp" name="http-listener-1"
> thread-pool="http-thread-pool-1">
> transport="tcp" name="http-listener-2"
> thread-pool="http-thread-pool">
> transport="tcp" name="admin-listener"
> thread-pool="admin-thread-pool">
>
>
>
>
>
>
> max-queue-size="256">
> idle-thread-timeout-seconds="3600">
> idle-thread-timeout-seconds="3600">
>
>
> That error:
> WARNING: GRIZZLY0023: Interrupting idle Thread:
> http-thread-pool-1-8080(1).
> SEVERE: java.lang.InterruptedException: sleep interrupted