Skip to main content

GlassFish error while deploy and no logging.

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
3 replies [Last post]
cjs1976
Offline
Joined: 2013-01-10

Hello!

I do my first steps with GlassFish. The installation was tricky, but I did it, and now I have a running GlassFish with the standard configuration. If I try to deploy my first webapp, I get the following error message:

***
Error An error occured

Error while Deployment: Exception while preparing the app : Invalid resource : myApp__pm. More informations in the server.log.
***

But I can't find this error in the server.log. There are other messages, but nothing about my webapp.

I need help please.

Thnaks,
Christian.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
hzhang_jn
Offline
Joined: 2005-07-22

Did your application need to use a resource called myApp_pm, but this
resource was not created?

On 1/10/2013 1:35 PM, forums@java.net wrote:
> Hello! I do my first steps with GlassFish. The installation was
> tricky, but I
> did it, and now I have a running GlassFish with the standard
> configuration.
> If I try to deploy my first webapp, I get the following error message:
> ***
> Error An error occured Error while Deployment: Exception while
> preparing the
> app : Invalid resource : myApp__pm. More informations in the
> server.log. ***
> But I can't find this error in the server.log. There are other
> messages, but
> nothing about my webapp. I need help please. Thnaks, Christian.
>
> --
>
> [Message sent by forum member 'cjs1976']
>
> View Post: http://forums.java.net/node/893771
>
>

mvatkina
Offline
Joined: 2005-04-04

__pm is an internal suffix. The actual name is myApp.

-marina
On 1/10/13 10:35 AM, forums@java.net wrote:
> Hello! I do my first steps with GlassFish. The installation was
> tricky, but I
> did it, and now I have a running GlassFish with the standard
> configuration.
> If I try to deploy my first webapp, I get the following error message:
> ***
> Error An error occured Error while Deployment: Exception while
> preparing the
> app : Invalid resource : myApp__pm. More informations in the
> server.log. ***
> But I can't find this error in the server.log. There are other
> messages, but
> nothing about my webapp. I need help please. Thnaks, Christian.
>
> --
>
> [Message sent by forum member 'cjs1976']
>
> View Post: http://forums.java.net/node/893771
>
>

cjs1976
Offline
Joined: 2013-01-10

Hello!

I found the failure... It was my fault ;-)

I had to add the MySQL-Connector, and to add an ressource under ressources (JDBC-Connection Pools and JDBC-Ressources), and than change my app to the parameters of this ressources.

Now it works!!!

Thanks,
Christian.