Skip to main content

Glassfish does not deploy ear-file correctly

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
3 replies [Last post]
pest1337
Offline
Joined: 2014-07-10

Hello,

I´m using Glassfish in version 3.1.2.2 build 5 (Open source edition) and want to deploy my ear-file. This is how I do this by using command line:
${GF_HOME}/bin/asadmin --user admin --passwordfile ${MY_BIN}/password.txt --host 127.0.0.1 --port 4848 deploy --name my_ear --target domain my_ear.ear

I´m getting a 'build successfull' but when I want to deactive it via GF-Webadmin-tool, I'm getting an error. If I open this deployed ear via Webadmin-tool (it shows me the content of the ear) and deactivate it afterwards, everything is fine.

No problems will occur, if I deploy via GF-Webadmin-tool and not by command line.

Can anybody tell me, what´s the difference between the command line and deploying with GF-Webadmin-tool?

Thanks in advance!

Best regards,
Stefan

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
reza_rahman
Offline
Joined: 2007-10-15

I'm afraid I don't quite follow. Can you kindly outline step-by-step the failure case (the success case does not matter much) and possibly attach the ear file in question?

pest1337
Offline
Joined: 2014-07-10

I´have found the solution:

As we are deploying on a standalone server, whe have to use --target server and not --target domain.

That fixes my problem!

reza_rahman
Offline
Joined: 2007-10-15

Excellent, thanks.