Skip to main content

Glassfish cluster instance restart blocks with JMS resources

Please note these forums are being decommissioned and use the new and improved forums at
2 replies [Last post]
Joined: 2013-12-05

We have the following glassfish 3.1.2 cluster instalation
M1 : DAS + instance 1
M2 : instance 2

In the cluster configuration we have the default settings for the JMS:

Using the default_JMS_host automatically created on cluster creation

Tried both EMBEDDED and LOCAL JMS Service Type using master broker with the default_JMS_host in Java Message Service in the cluster configuration

We created the following JMS resources:

JMS Connection Factory of type QueueConnectionFactory with the cluster as target (also tried target server, and both)
JMS Destination Resource of type Queue with the cluster as target (also tried target server, and both)

After creation, if we deploy an application using that queue both producers and consumer works perfectly.

The problem is, if we restart the instance (even without the application using the queue deployed) the start procedure of the instance blocks without any exception/error in instance server log nor in instance imq log.

(if we delete JMS Connection Factory and JMS Destination Resources the instance restarts without problem)

Any solution known? What am i missing here?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Joined: 2007-09-10

I'v tried creating JMS QueueConnectionFactory and Queue resources targeting to a 2-instance cluster with GlassFish, and start cluster, then stop cluster, then restart each instance individually, works fine. One important thing to note is that the 'Node Host' of a Node must not set to 'localhost' (This is especially important for the default Node localhost-domain1 has its 'Node Host' as 'localhost' by default, if you are using localhost-domain1 for 1 of the instances, you must change its 'Node Host' to the system's real hostname or IP address), see GlassFish doc jira

GLASSFISH-20602 affects JMS forming cluster and by itself doesn't cause 'restart block' which may likely be something specific to your setup environment. Thread dumps and complete log files of server instances and brokers, best a test case to reproduce the problem and a detailed description of exactly what do you mean by 'restart block' would be helpful.

Joined: 2011-11-08

Have you taken a thread dump of the instance to see which thread is stuck? Maybe then you get a better idea what the problem could be.