Skip to main content

Glassfish Admin Console Language Locale

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
4 replies [Last post]
Anonymous

He there.

How can I change the language used in the Glassfish Admin Console?

This is Glassfish 3.1.1 running on CentOS 6.1 and the admin console uses german. I found this thread but none of the things mentioned there worked for me.

Any ideas?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
anilam
Offline
Joined: 2005-03-29

heroman wrote:

How can I change the language used in the Glassfish Admin Console?

Admin Console uses the browser's locale, so, all you need to do is set your browser's locale to the language you want and it will be using the new locale on the next screen refresh. No restart is needed.

And of course, you need to install the multi-language distribution from http://glassfish.java.net/downloads/3.1.1-final.html

Hope this help.

Anissa.

heroman

Putting english to the front of the accepted languages (intl.accept_languages in Firefox) did change the language of the admin console.

Thanks a lot Anissa.

alexismp
Offline
Joined: 2005-01-06

Assuming you have a Multilingual GlassFish install (the -ml archives on http://glassfish.java.net/downloads/3.1.1-final.html for instance), you should be able to force it using a -Duser.language property (asadmin create-jvm-options -Duser.language=zh_CN)
-Alexis

On 9 févr. 2012, at 13:48, forums@java.net wrote:

> He there.
>
> How can I change the language used in the Glassfish Admin Console?
>
> This is Glassfish 3.1.1 running on CentOS 6.1 and the admin console uses
> german. I found this thread [1]but none of the things mentioned there worked
> for me.
>
> Any ideas?
>
>
> [1] http://www.java.net/node/681218
>
> --
>
> [Message sent by forum member 'heroman']
>
> View Post: http://forums.java.net/node/883389
>
>

heroman

No luck with the user.language option. But changing the browser's accepted languages did help (see post above).

Thanks anyway.