Skip to main content

Glassfish 3.1.2.2 and maxParameterCount

2 replies [Last post]
mward_ssi
Offline
Joined: 2010-10-16
Points: 0

We have a page on an application deployed in Glassfish 3.1.2.2 that has over 10,000 fields (both hidden and displayed) that get submitted via POST to the server. When the page is submitted, the server logs spit out:

WARNING: More than the maximum number of request parameters (GET plus POST) for a single request([10,000]) were detected. Any parameters beyond this limit have been ignored. To change this limit, set the maxParameterCount attribute on the Connector.

I've seen other posts on increasing it for JBoss using a system property on startup, but that doesn't work here. I've also tried setting that property on various connector XML attributes in domain.xml without any success, nor have I been able to find any UI control in the admin where that would be set.

Does anyone have any information where this parameter can be changed at so that this Post request works?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
oleksiys
Offline
Joined: 2006-01-25
Points: 0

Unfortunately this feature is not implemented in Glassfish 3.1.2.2.
You may want to use either Glassfish 4 or Glassfish 3.1.2.5*

The command to set max parameters looks like:
$ asadmin set server.network-config.protocols.protocol.{protocol_name}.http.max-request-parameters
where {protocol_name} is the name of the protocol for example "http-listener-1"

WBR,

* Glassfish 3.1.2.5+ is only available via Oracle support https://blogs.oracle.com/GlassFishForBusiness/entry/oracle_glassfish_ser...

AndyOverton
Offline
Joined: 2013-08-02
Points: 0

Hi,

You can set the value using the asadmin set command, as follows:

asadmin set server.network-config.protocols.protocol.admin-listener.http.max-request-parameters=number_of_requests

Hope this helps,

Andy Overton

C2B2 Expert Support
http://www.c2b2.co.uk/support