Skip to main content

Glassfish 3.1.2 - Is RMI-IIOP Per-Request Load Balancing broken in 3.1.2?

1 reply [Last post]
wesley_strickland
Offline
Joined: 2013-04-19
Points: 0

Per-request load balancing does not seem to work when following these instructions to configure load balancing for a stateless EJB:

http://docs.oracle.com/cd/E26576_01/doc.312/e24934/rmi-iiop.htm#gknpv

Requests from a single client seem to always go to the first node in the cluster and never load balance as if it was still using Initial Context load balancing. My glassfish-ejb-jar.xml file is attached with the per-request-load-balancing set to true:

I know the file is being parsed and there are no parsing errors.

I also turned the logging level up to FINEST for Corba within the cluster and I see other log messages at the FINE level but I never see the log message that the Oracle instructions say I should see that per-request-load-balancing has been turned on for my EJB:

"Verify the PRLB configuration by looking for the following FINE message in the CORBA log file:

Setting per-request-load-balancing policyfor EJB EJB-name"

I don't know if I am missing some other configuration or if RMI per request load balancing is broken in 3.1.2?

Any help would be greatly appreciated!

Thanks!
-Wes

AttachmentSize
glassfish-ejb-jar.txt933 bytes

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
twistah
Offline
Joined: 2006-06-15
Points: 0

We have experienced the same problems. However, if you read the docs word for word it actually describes a load balancing strategy that only use ONE node.

Quote: "PRLB chooses the first node in a cluster to use on each request."

You may ask "...and then what?" and that would be a good question. :)

So in essence the server is acting the way the docs says.
I have notified the Glassfish team about this strange formulation, but have gotten no response.