Skip to main content

GF4 Applications logs don't show up in node logs (clustered environment)

Please note these forums are being decommissioned and use the new and improved forums at
1 reply [Last post]
Joined: 2012-06-01

Hi all,

I've created a couple nodes cluster with GF 4.0.1-b04-09_11_2013 an deployed a simple JAX-RS 2.0 app [1]. And while the app show logs both in integration-tests (GF Embedded 4.0) and when I deploy the app in the DAS (not clustered), the same doesn't happen when deploying the app in the cluster.

Also, I only see app deployment logs (in the nodes) if I restart the cluster and not if I redeploy the app or undeploy/deploy it.

Am I missing some configuration?

Paulo Pires

1 - App source-code with integration tests at

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Joined: 2012-06-01

Tried it with example and had same result.

Using Ubuntu 12.04.3, OpenJDK 7 and glassfish-4.0.1-b04-09_21_2013.