Skip to main content

Getting 0 bytes JAR in EAR

1 reply [Last post]
markof19
Offline
Joined: 2012-05-30
Points: 0

Hello,

I have EJB-2 and EJB-2 ejb project, a WAR project and CommonUtuil libary project (used by EJB-2, EJB-3 and WAR) - all added to MyEAR project

I added added the EJBs, WAR and the CommonUtil library to MyEAR.ear.

Yesterday I am able to build the EAR and run my web app just fine.

Today, I started t Netbeans. some notification pops up asking me to update and download some plugin ( I believe its ANT and EJB related...).

I then build and deploy my ear, but deployment failed due to the error in the EJB & WAR because a class in CommonUtil.jar is missing.

When I opened the built MyEAR.ear, I saw the CommonUtil.jar inside it having the size of 0. However other 3rd JARs are OK, only my JARs (CommonUtil,... .jar) have size 0.

When I build CommonUtil.jar sepately, I can see the jar of some size being generated. But the one in the EAR is 0 size.

This is similar to : http://stackoverflow.com/questions/9982914/ant-build-producing-0-byte-ja...

Is this due to a regression in Netbeans from the update that I did ?
Can anyone tell me how I can resolve this ?

Thanks

Mark
Product Version: NetBeans IDE 7.4 (Build 201310111528)
Updates: NetBeans IDE is updated to version NetBeans 7.4 Patch 2
Java: 1.7.0_45; Java HotSpot(TM) 64-Bit Server VM 24.45-b08
Runtime: Java(TM) SE Runtime Environment 1.7.0_45-b18
System: Windows 7 version 6.1 running on amd64; Cp1252; en_US (nb)

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
markof19
Offline
Joined: 2012-05-30
Points: 0

I was CUI (coding under influence) last night. Just read my posting after sobering up this morning....

This is a Netbeans issue ( however, i still welcome any pointers if someone have a solution)