Skip to main content

Disabling embedded OpenMQ authentication

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
No replies
Andrew_Scully
Offline
Joined: 2013-01-18

Hello,

I would appreciate it if someone could point me in the right direction with regards to a setup problem I'm having, starting up and connecting to an embedded OpenMQ broker.

Firstly, apologies if this isn't the correct forum for this question. All of the links for OpenMQ-specific forums I found were dead, but please direct me elsewhere if you know better.

The scenario:
I am attempting to create an in-VM, standalone OpenMQ server to run maven / Junit tests against, so that we can test our JMS integration during the test phase of our builds.

I am able to startup the embedded broker, but I get authentication errors when I try to connect to it (i.e. using com.sun.messaging.ConnectionFactory.createConnection()).

Firstly, is it expected behavior for authentication to be required when connecting to a local broker? I only ask because this differs from other JMS vendors I have used, where only remote connections required authentication?

Regardless, authentication isn't required for our particular scenario. I've tried disabling authentication on the broker, following the instructions in the documentation, but without success.
-I have added imq.accesscontrol.enabled=false to both $IMQ_HOME\lib\props\broker\ properties files and the $VAR_HOME\instances\imqbroker\props\config.properties file.
-The behavior doesn't change, authentication errors are still thrown on connection.

So my questions are, how do I disable authentication on my embedded broker (and should I have to with local connections)?

If there is no way to disable authentication, what recommendations would you have for my scenario?

A zip file of a test project and the output I'm getting are attached.

Thanks, Andrew Scully.

AttachmentSize
openmq-issue.zip6.11 KB
console_output.txt9.02 KB