Skip to main content

Default Web Module

1 reply [Last post]
schnocky
Offline
Joined: 2003-11-03
Points: 0

I want my web app to be the default application when someone comes to my server on my https port. I set

server.http-service.virtual-server.server.default-web-module in domain.xml to my web app. The first time Glassfish is started, it is not the default. Subsequent starts/restarts and it is the default. My current workaround is to set the

server.http-service.virtual-server.server.default-web-module using run at startup in a servlet in my webapp.

Am I doing something wrong? Is there a better way to do this?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
swchan2
Offline
Joined: 2005-03-29
Points: 0

What is the version of GlassFish that you use?
What error do you see in server.log in the first time GlassFish start?