Skip to main content

connector-connection-pool is not working

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
No replies
krishnathanuku
Offline
Joined: 2013-06-20

Hi all,

I am trying from many days to fix an issue. We are using glassfish + jms (amq).

As part of performance testing I tried to send too many requests to our application and then I received some corba exception like this

Caused by: javax.transaction.SystemException: 
org.omg.CORBA.INTERNAL: JTS5031: Exception
[org.omg.CORBA.INTERNAL:  vmcid: 0x0  minor code:
0 completed: Maybe] on Resource [commit one phase]
operation.  vmcid: 0x0  minor code: 0  completed: No

I also received some exceptions like

Quote:
Unexpected end-of-file encountered
Then I came to know that the servlet thread pool is set to its default size 5. Then I increased the thread pool to 100 for now and later I dint observer the second exception.

Then I tried to send too many requests again. This time I received another exception apart from corba exception.

[#|2013-06-19T09:52:00.886+0100|WARNING|
glassfish3.1.2|javax.enterprise.resource.
resourceadapter.com.sun.enterprise.connectors
|_ThreadID=29;_ThreadName=Thread-2;|RAR5117 :
Failed to obtain/create connection from connection
pool [ { PoolInfo : (name=java:app/amqpool),
(applicationName=nms_shm) } ]. Reason : com.sun.appserv.connectors.internal.api.PoolingException:
In-use connections equal max-pool-size and
expired max-wait-time. Cannot allocate more
connections.|#]

Then I understood that I have to increase the connection pool size.

I increased the pool size in our glassfish-resources.xml and redeployed the application, restarted the server and have send 50 requests, from which few of them failed with the same exception again and other exceptions. The connection pool size is not taking effect. From the documentation I read that the default size is 32. But after increasing the size glassfish is only creating max 30 connections. If I leave it to default glassfish is creating all 32 as per need.

The resource manager is doing work 
outside a global transaction
javax.transaction.xa.XAException

Then later I thought something might be wrong in the transaction management and then I configured XATransaction and max-wait-timeout-in-millis to 0 on the pool in my glassfish-resources.xml. Then I redeployed the application, restarted the server and have sent 20 request. This time glassfish created almost 36 connections. This time, for few requests the time taken to receive the response from the server increased a lot. In the glassfish server logs again I could see corba exceptions.

Can anyone please help me fix this problem. This will really be a big help for me. Thank you all in advance.