Skip to main content

Change master password

4 replies [Last post]
fcontreras
Offline
Joined: 2010-12-18
Points: 0

Hello guys

I have the following problem with a new install of glassfish. I just download it and unzip it on some folder, then installed artifactory.

So after setting this app I decided to change my master password to enable the ssl after. But when i try to "./asadmin change-master-password domain1" and type "changeit" and the new password it says.

Keystore was tampered with, or password was incorrect

I have not changed the original keystore.jks that comes with the glassfish files. and also verified with the keytool that the actual password of the keystore is still "changeit" by using "keytool -list".

So im not sure where else to look for.... can you light the road a bit for me.

Thanks in advantage.

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
tmueller
Offline
Joined: 2005-10-31
Points: 0

What version of GlassFish are you using?
Can you please run the command with AS_DEBUG=true to see if there is
additional output that might reveal the source of the problem?

Tom

fcontreras
Offline
Joined: 2010-12-18
Points: 0

Hello, Thanks for your reply my glassfish version is 3.1 and this is the output with AS_DEBUG enabled

./asadmin change-master-password domain1
CLASSPATH= ./../glassfish/modules/admin-cli.jar
Commands: [change-master-password, domain1]
asadmin extension directory: /home/frank/glassfish3/glassfish/lib/asadmin
Prepare
Process program options
Parsing program options
Parse command options
params: {}
operands: [domain1]
Prevalidate command options
Inject command options
Validate command options
asadmin --host localhost --port 4848 --interactive=true --echo=false --terse=false change-master-password --savemasterpassword=false domain1
Execute command
Prepare
Process program options
Parsing program options
Parse command options
params: {}
operands: [domain1]
Prevalidate command options
Inject command options
Validate command options
Setting password to: <non-null>
Using local password
asadmin --host localhost --port 4848 --interactive=true --echo=false --terse=false _change-master-password-das --savemasterpassword=false domain1
Execute command

isRunning got exception: java.net.ConnectException: Connection refused
Enter the current master password>
Enter the new master password>
Enter the new master password again>
Keystore was tampered with, or password was incorrect
Command change-master-password failed.

tmueller
Offline
Joined: 2005-10-31
Points: 0

The change-master-password command actually modifies several files:

config/domain-passwords
config/keystore.jks
config/cacerts.jks
config/master-password

If any of these files has a password that is different from the one in
master-password, then I expect this message would be generated.

If you want to file a bug against change-master-password that it should
output clearer information about what is wrong, please do so (once it is
determined what is actually wrong ;-)).

Thanks.
Tom

moessi91
Offline
Joined: 2013-06-21
Points: 0

Hello, I'm facing the same problems. I don't know what I should do now because I didn't change anything. Is there a way to get these files again?
config/domain-passwords
config/keystore.jks
config/cacerts.jks
config/master-password
I mean can i replace them with the default files of a freshly installed glassfish server and then try again? what would you recommand to do?

Lg