Skip to main content

Can't login to admin console (Internal GlassFish 3.1.1)

12 replies [Last post]
kwutzke
Offline
Joined: 2006-03-08
Points: 0

Hello,

I'm new to GlassFish. I've installed GlassFish 3.1.1 via the Eclipse Oracle utility plugin which gave me an Internal GlassFish 3.1.1 under Servers. (I needed to change the main port to 8081, but I don't think it matters.)

Server startup is fine, I can see the welcome page from which I go to the admin login. At the login neither entering admin//adminadmin nor admin//[empty password] is allowing me access to the admin console.

What's wrong? What's my password? Isn't one set automatically?

Karsten

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
ilkinabdullayev
Offline
Joined: 2013-02-24
Points: 0

1.C:\Program Files\glassfish-x.x\glassfish\bin
2.asadmin run(as Administrator)
3.get domain list
asadmin>list-domains
4.create new domain
asadmin>create-domain --instanceport 4141 --adminport 5151 ilkin
5.start domain
start-domain ilkin
-------------------
Result:
AdminPort:5151
InstancePort:4141
-------------------

snotty77
Offline
Joined: 2012-02-27
Points: 0

I think you are using jdk 1.7. Try to start glasfish with jdk 1.6.31. Change it directly in the env-shell/bat. This solved the problem for me. There is an authentication module in glassfish wich won´t start with 1.7

Greetings

Snotty

kwutzke
Offline
Joined: 2006-03-08
Points: 0

Hello snotty77,

thanks for this info. You're absolutely correct, I'm using JDK 1.7. Strangely enough when visiting http://glassfish.java.net/ it reads "• July 2011 - GlassFish 3.1.1 now available. Now with Java 7 support." It's sometimes amazing, you start with some new server and even before even deploying the first webapp you get over the limit. What shall I say?

Do you happen to know which module that was? I cannot find anything here http://docs.oracle.com/cd/E18930_01/html/821-2434/ggrvi.html

Is there another way to configure datasources in GlassFish 3.1.1, that is without the admin console?

Karsten

PS: Is the admin console much needed? On JBoss AS 7 I didn't use the admin tool at all, so I might install a JDK 1.6.x, configure the datasource and begone.

snotty77
Offline
Joined: 2012-02-27
Points: 0

You only have to start glassfish and then start the admin console. You have the error message in the serverlog. I have deletet mine after switching to jdk 1.6 so I can´t tell. Even if you install in compination with netbeans the console works for the first time. After deploying your first app you get this strange behavior. maybe it is only a windows problem. I have read about some Windows issues which are solved through installation by "zip".

You can configure your datasources with netbeans or by directly editing the apropriate config files with your favourite editor.

PS: If I could rely on the fact that only the admin-console was affected by the jdk 1.7 I would not think about it any longer, but there may be more modules with some errors which will catch me when I have no time for solving or investigating in this issues!

anilam
Offline
Joined: 2005-03-29
Points: 0

We discovered the JDK 1.7 issues when testing GlassFish 3.1.2. A couple of bugs has been filed for using JDK 1.7 and you are right that other modules is affected as well.

You can look at http://java.net/jira/browse/GLASSFISH-18133 which also has links and info of other GlassFish bugs affected by JDK 1.7. The change in behavior in JDK 1.7 has been filed as http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=7023180.

The GlassFish issues are fixed in 3.1.2 which will be released on 2/29 according to the plan posted in http://wikis.oracle.com/display/GlassFish/GlassFishV3Schedule . So you may want to update to GlassFish 3.1.2 if you need JDK 1.7.

kwutzke
Offline
Joined: 2006-03-08
Points: 0

@Anilam:

Can you tell if there are any core modules affected? I just need a standard webapp deployed as WAR (persistence, transactions, security) to be working. The issue posted is for clustering, which isn't needed.

Will the GlassFish Eclipse plugins be updated immediately to support GlassFish 3.1.2? Edit: The indigo plugins already include a GlassFish 3.1.2 runtime.

Karsten

vbkraemer
Offline
Joined: 2003-09-03
Points: 0

Hi Karsten,

The server adapter available @ http://download.java.net/glassfish/eclipse/indigo should let you register a 3.1.2 server that you have 'installed' (by unzipping it) after you download it from http://download.java.net/glassfish/3.1.2/promoted.

Once 3.1.2 ships we will create 3.1.2 run-time plugin that will automagically register a 3.1.2 server into Indigo SR2 and recent Juno builds. The new run-time plugin will appear that these two update sites:

http://download.java.net/glassfish/eclipse/indigo and http://download.java.net/glassfish/eclipse/juno.

vbk

kwutzke
Offline
Joined: 2006-03-08
Points: 0

Thanks Vince for your insight.

As GF 3.1.2 is just around the corner I'll probably wait for the final release. Is it in time? Will it be available on Feb 29th?

Oh, while you're at it, could you please have a look at this problem?: http://www.java.net/forum/topic/glassfish/glassfish-plugins/overriding-t...

Karsten

anilam
Offline
Joined: 2005-03-29
Points: 0

Hi Karsten,
GlassFish 3.1.2 is released today !! Check it out !!

https://blogs.oracle.com/theaquarium/entry/glassfish_3_1_2_final
http://glassfish.java.net/downloads/3.1.2-final.html

Anissa.

On 2/28/12 3:36 PM, forums@java.net wrote:
> As GF 3.1.2 is just around the corner I'll probably wait for the final
> release. Is it in time? Will it be available on Feb 29th?
>
> Karsten
> --
> View Post: http://forums.java.net/node/883805
>
>

kwutzke
Offline
Joined: 2006-03-08
Points: 0

Yes I've already got it to work yesterday, thanks. Admin console login works now.

Karsten

anilam
Offline
Joined: 2005-03-29
Points: 0

kwutzke wrote:

Can you tell if there are any core modules affected? I just need a standard webapp deployed as WAR (persistence, transactions, security) to be working. The issue posted is for clustering, which isn't needed.

Will the GlassFish Eclipse plugins be updated immediately to support GlassFish 3.1.2? Edit: The indigo plugins already include a GlassFish 3.1.2 runtime.

Karsten

I don't know which modules will be affected. There are tasks just filed and assigned to each of the modules to inspect if it will be affected in the unreleased version. Here is the list

http://java.net/jira/secure/IssueNavigator.jspa?reset=true&jqlQuery=proj...

As for the GlassFish Eclipse plugins, will check with Vince Kraemer.

Anissa.

kwutzke
Offline
Joined: 2006-03-08
Points: 0

Anissa, thanks for helping me.

Regards, Karsten