Skip to main content

Can anyone translate this lengthy error in to plain English?

Please note these forums are being decommissioned and use the new and improved forums at
1 reply [Last post]
Joined: 2007-02-26
Points: 0

I'm trying to install a war file into Glassfish 4 using the admin interface. The project was built with the Google Web Toolkit, and if it makes any difference, the IDE I'm using is Eclipse-Kepler built using Eclipse IDE. I do not understand the getting an error that I do not understand the error I'm getting while trying to install the application. Below is the error that appears in the raw log:

[2014-05-22T22:12:15.568-0700] [glassfish 4.0] [SEVERE] [] [javax.enterprise.system.core] [tid: _ThreadID=128 _ThreadName=admin-listener(7)] [timeMillis: 1400821935568] [levelValue: 1000] [[ Exception while loading the app : CDI deployment failure:WELD-001408 Unsatisfied dependencies for type [Set] with qualifiers [@Default] at injection point [[BackedAnnotatedParameter] Parameter 1 of [BackedAnnotatedConstructor] @Inject]
org.jboss.weld.exceptions.DeploymentException: WELD-001408 Unsatisfied dependencies for type [Set] with qualifiers [@Default] at injection point [[BackedAnnotatedParameter] Parameter 1 of [BackedAnnotatedConstructor] @Inject]

As you can well imagine, I can't even begin to fix the problem if I don't even understand the error (and why is org.jboss in the error. I don't even have any jboss tools installed in Eclipse).

Can anyone translate that error for me?

~ Rob

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Joined: 2010-11-15
Points: 0

I will guess the problem that you are running into is that you are trying to deploy a war file that includes Guava. This is known to not work in GlassFish 4 out of the box - see issue:

The problem is that CDI (jboss weld) is overly aggressive in its classpath scanning by default. You can disable this with:

asadmin set configs.config.server-config.cdi-service.enable-implicit-cdi=false