Skip to main content

building glassfish with 4.0 features

Please note these forums are being decommissioned and use the new and improved forums at
4 replies [Last post]
Joined: 2012-02-12

Hi! I tried to follow instructions from those sites:

but I am unable to achieve a distribution with asadmin script that would recognise commands like create-ims-config-native etc...

Here's what I do:
1. svn update main (update glassfish to it's newest revision)
2. mvn install -Dmaven.test.skip=true
3. extract glassfish from main/appserver/distributions/glassfish/target/
4. go to <extracted glassfish>/bin/
5. execute asadmin start-domain
6. execute asadmin create-ims-config-native

and 6 step returns:
CLI001 Invalid Command, create-ims-config-native. Use "asadmin help" for a list of valid commands.

What do I do wrong?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Joined: 2011-04-01

Hi Piotr,

I cannot test it right now, but it looks like the virtualization jars are not present in your module folder. Can you check that you can find these jars (for example libvirt.jar and virt-core.jar) into your "[extracted archive]/glassfish/modules" folder ? If they are missing, could you please try to take all the jars built in nucleus/virtualization and copy them in your modules folder ?


Joined: 2012-02-12

Thanks for reply Fabien. Unfortunately it didn't worked. I recorded short movie to simplify things... which I extract is freshly after mvn clean install. Everything else I guess you should be able to figure out from movie. I copied movie into my student space. You can find it under:

Feel free to ask anyting and thank you for help


Joined: 2005-10-31

It appears that your PATH doesn't include the current directory before
some other directory that has "asadmin" in it. Therefore, when you are
entering the "asadmin" command you are getting some other asadmin for
some other GlassFish install. Try using "./asadmin".

"type asadmin" will tell you what asadmin you are actually getting.


Joined: 2012-02-12

I wonder why I had glassfish under /usr/appserver and asadmin link in /usr/sbin

Eh... never mind. Problem's solved! It's a shame I didn't notice it earlier... Thank you Fabien and thank you Tom... guess I need to be more attentive in future