Skip to main content

application jars not found

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
No replies
frank_curzon
Offline
Joined: 2013-03-05

hi,
i'm running the latest version of glassfish server with a web project using struts 1, mysql and mybatis for database access. all application specific libraries i put into the glassfish/domains/mydomain/lib folder.
when i deploy the project from netbeans 7.2.1 all is working but when i start glassfish alone and deploy the application the project is not working

16:20:51,454 ERROR [DataAccessImpl] PROBLEM INITIALISING SqlSessionFactory: org.apache.ibatis.exceptions.PersistenceException:
### Error building SqlSession.
### The error may exist in SQL Mapper Configuration
### Cause: org.apache.ibatis.builder.BuilderException: Error parsing SQL Mapper Configuration. Cause: org.apache.ibatis.builder.BuilderException: Error creating instance. Cause: java.lang.IllegalStateException: Cannot enable lazy loading because CGLIB is not available. Add CGLIB to your classpath.
16:20:51,548 ERROR [DataAccessImpl] NO _sqlSessionFactory FOUND
16:20:51,548 ERROR [DataAccessImpl] NO _sqlSessionFactory FOUND
16:20:51,548 ERROR [DataAccessImpl] NO _sqlSessionFactory FOUND
16:20:51,548 WARN [AbstractExceptionHandler] Unhandled exception
java.lang.NullPointerException
at actions.MainPageAction.execute(MainPageAction.java:63)

indicating that the application libraries aren't found.

- i tried putting the libraries into any other subfolder of domain/mydomain/lib which didn't work
- deploying the libraries within the war didn't work
- setting the libraries from the admin console during deploy didn't work as well as using path settings under JVM settings.

i spend now many days on it and don't know what else to try. when running it from netbeans it works fine. not sure what it does different.

tx. for the help,
frank