Skip to main content

Jsf 2.0 Complete Reference Virtual Trainer Applicaion setup problem

No replies
roimekoi
Offline
Joined: 2014-01-06
Points: 0

Before anyone start to read, i want to apologize for my bad English.

First, some of the virtual trainer dependencies seems not in maven repository anymore and so what i modified to the original pom file is in the pastebin, the version are closed to the original one such as 2.0.0-M7 to 2.0.0.
http://pastebin.com/aLByi0nU

After maven download all the new dependencies. the program compile with no error,
Then i create the 'trainer' database through netbean and when the program runs, it creates the db schema with no problem, however the new tables are empty even though there are postConstruct annotation in the UserRegistry.java and EventRegistry.java ..

I tried to add record to directly to from sql and debug from register.xhml , stepping through the breakpoint, the new record that i manually inserted got retrieved and when compared with the new userid, it failed to register new user,
so i comment out this line " //result = (null != registry.getUserByUserid(value)); "
in UseridUniquenessConstraintValidator.isUserValid method,
it was able to create the new user session, however the new user info is still not saved inside the trainer database. but i am able to navigate to other page with no problem

After trying for a few days but with no success i think the problem lies in the some of the dependency version that i modified in the original pom file.

Thanks for your help

regards,
roi