Skip to main content

[javax.sql.Datasource] is not an allowed property value type.

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
2 replies [Last post]
rbambati
Offline
Joined: 2011-06-03

Hi,

I am getting the following error while deploying .war file.

[javax.sql.Datasource] is not an allowed property value type.

actually i had created datasources succefully. Now those are pinging also.

Can any body help on this......

Regards,

Rams

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
goosterman
Offline
Joined: 2011-06-15

Hi,

I had a similar problem when switching from Netbeans 6.9 to 7.0. Try spelling Datasource as DataSource.

Paul

rbambati
Offline
Joined: 2011-06-03

Hi,

I found the solution for that. The solution for that is we need to remove the data source references from the web.xml. Glassfish is different from other servers. And also not require context.xml file. now i got deployed my .war properly. But now it is showing at runtime full jdk is required but not jre.

But in my pc full jdk is there and i have setted in environment also but it is not recognizing. By default glassfish application server identifying jre only. Any body known how to change java path in glassfish from jre to jdk.

can any body help on this.