Skip to main content

Configuring a remote Glassfish Node

Please note these java.net forums are being decommissioned and use the new and improved forums at https://community.oracle.com/community/java.
1 reply [Last post]
johnny.poison
Offline
Joined: 2013-05-11

My DAS is running on windows 7, and I'm trying to configure a remote node on linux. I am attempting to connect via SSH with no pass phrase, just a private key but I am not able to connect. I can, however, successfully connect using the same key file using Putty or FileZilla. Does anyone know what the problem might be? Below is the error I'm getting along with some of my settings. Thanks in advance.

Warning: some parameters appear to be invalid. Node not updated. To force an update of the node with these parameters rerun the command using the --force option. Could not connect to host MYHOST.com using SSH. Could not authenticate.

Name:linux_test_domain

Type: SSH

Node Host: MYHOST.COM

Node Directory: linuxNodeTestDirectory

Installation Directory: /usr/glassfish/glassfish3

The full path to the parent of the base installation directory of the GlassFish Server software on the host, for example, /export/glassfish3.

SSH
Force: Not Enabled

SSH Port: 22

SSH User Name: ec2-user

SSH User Authentication: Key File

Setup SSH: Not Enabled

Key File: C:\Users\jack\ssh\Roy.ppk

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
mcroft
Offline
Joined: 2013-08-06

What command did you use to get that error message? It looks to me like the problem is that SSH has not been set up between the two hosts.

Before you can connect over SSH with a key file, you need to let the remote asadmin know that you want to establish connections using that key from that specific server. For that you'll need the setup-ssh asadmin command:

http://docs.oracle.com/cd/E18930_01/html/821-2433/setup-ssh-1.html

So in your case, you would need to run the command:
setup-ssh --sshuser ec2-user --keyfile <private-key-file> --sshpublickeyfile C:\Users\jack\ssh\Roy.ppk

Hope that helps.

Mike Croft
C2B2 Expert Support