Skip to main content

Problem debugging GlassFish 3.1 in Helios

Please note these forums are being decommissioned and use the new and improved forums at
7 replies [Last post]
Joined: 2011-05-27

When using Helios to debug GlassFish I have a problem where the debugger doesn't highlight the appropriate source line on breakpoints or while stepping. If you manual identify the suspended thread in the debug tab and double click it you do see the selected line and can inspect variables normally. However as soon as you step on you lose the debug point highlighting. This effectively makes the debugger useless.

I have a workaround which is to set up a new Remote Java Application debug configuration connecting to the glassfish server on port 9009. If the server is launched in the server view and then you disconnect the debugger, you can launch the Remote Java Application debug configuration. This then works correctly.

It's not a major problem but it would be nice to have a fix, whether it's something I've done or a problem with one of the components of the environment.

The environment is a clean install of jdk-6u25-windows-i586, eclipse-jee-helios-SR2-win32, glassfish 3.1 (downloaded and installed using New Server - Download) and GlassFish plug-in installed using the Eclipse Update Center url

I think this is the same problem as that discussed:

But the solutions described, namely using a sun jdk > 1.6.0_22-b04 and installing glassfish through Servers → New → Server → Download additional server adapters don't seem to work for me.

Anyone seen this or know of a solution?

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Joined: 2003-09-03

I am using a recent release of the Eclipse (Indigo/sr1) and the plugin ( and I do not have this problem.

To get the plugin, go to

Let me know if you run into problems from a recent build of Eclipse and the plugin.


Joined: 2011-12-16

Just tried installing the plugin today, doesn't work. Here's how I tried:

  • Downloaded Eclipse jee indigo win32 x86_64 from
  • Extracted, ran Eclipse.exe
  • Help -> Install New Software
  • Added "" in the Work with column
  • Check "GlassFish Application Server"
  • Next, Next, accept license, Finish....
  • After downloading, I get this error:

An error occurred while collecting items to be installed

session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).

No repository found containing: osgi.bundle,,

No repository found containing: osgi.bundle,,

No repository found containing: osgi.bundle,,

No repository found containing: org.eclipse.update.feature,,

No repository found containing: org.eclipse.update.feature,,

I hope it's just a naming typo!


Joined: 2011-06-01

Same configuration, same problem here.
I've installed plugin version, as you say installing plugin from Server -> New -> ... debug for someone works.The only difference I see is that following this method the plugin version is older
I'll make a try.
In the meantime did you find any solution?
EDIT#1: The really strange thing is that sometimes it works, sometimes don't! Damn

Joined: 2010-10-11

I have same configuration and same problem, as I remember the problem starts after I changed the Glassfish from 3.0.1 to 3.1.

Joined: 2011-05-27

No, I didn't get any further. I just have to kill the first debugger connection and restart it. As you say it's odd it sometimes works, though mostly doesn't for me. :-(

Joined: 2008-12-26

This problem still happens. Very pity, that nothing was done during so long time.... Remote debug is uncomfortable and usually have to restart it and place breakpoints again on each redeploy.

Will anything be done with this problem???

Joined: 2011-11-02

We think it may be related to the plugin. Created an issue in JIRA: