Skip to main content

Eclipse -> GlassFish 3.1.1: Credential_Error

Please note these forums are being decommissioned and use the new and improved forums at
1 reply [Last post]
Joined: 2011-09-13


I am a newbie in J2EE (but decades of J2SE development) and trying several samples with Eclipse and GlassFish.

The first steps (simple JSP) worked fine. I could deploy the application and see them in my browser.

But after I started a Java Server Faces project I could not run/deploy applications from Eclipse anymore.

I always get the message:

The Eclipse plugin cannot communicate with the GlassFish server, status is :CREDENTIAL_ERROR

I reinstalled a fresh eclipse (went back from 3.7 to 3.6), I reinstalled a second copy of Glassfish. No change.

Even the simple JSP files now give me the same error message.

I still can deploy ready WAR samples using GlassFish's Admin interface.

Both Eclipse 3.6 (Helios SR2) and GlassFish (3.1.1) are running on a local Windows 7 box, so the server is at localhost.

I also installed the Oracle Glass Fish Tools (

Any ideas?



Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Joined: 2003-09-03

I started to look through the code and it seems like CREDENTIAL_ERROR is used ambiguosly in

If the LocationCommand fails, we assume that there is a C_E.

If the LocationCommand has not succeedded and not failed... is still running??.. there is also a C_E...

I am investigating.