Skip to main content

Secure Web SSL Transport Layer Security - https not throws runtime exception - http says, hey you should be https

Please note these forums are being decommissioned and use the new and improved forums at
1 reply [Last post]
Joined: 2011-07-30

Hi all,
Very green programmer.

Follow a few tutorials to the letter. Finally was able to get a non ssl'd webservice connection to tell me this:

[#|2011-08-07T08:59:48.599-0500|SEVERE|glassfish3.0.1|com.sun.xml.wss.provider.wsit|_ThreadID=32;_ThreadName=Thread-1;|WSITPVD0035: Error in Verifying Security in Inbound Message.
com.sun.xml.wss.XWSSecurityException: WSS1601: Security Requirements not met - Transport binding configured in policy but incoming message was not SSL enabled

This is good! - This means someone is talking enough to know it needs ssl.

So I recreated the same simple client using the https:// version.
I am using the default s1as keys, btw.

Now when I run the client I get this:

Exception in thread "main" Cannot find 'https://localhost:8181/rtcalcapp/CalculatorWSService?wsdl' wsdl. Place the resource correctly in the classpath.

at rtclient4.Main.main(
Java Result: 1

What am I doing wrong.... I am stumped...


Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Joined: 2011-07-30

This link describes some workaround for what I described in the last message:

Using Netbeans:

create a web service client
point at https://domain/webservice/webservice?wsdl
then after it generates itself
delete webservice under webservice refrences node

Recreate webservice by pointing at the .wsdl up under src/META-INF/wsdl/[service name]/[webservice deploy name]/[saved webservice .wsdl file]

then you can actually hit the https:// webservice

(then it becomes a certificate keystore wsit soap policy nightmare)