Skip to main content

Can't install Java - Permission Denied

1 reply [Last post]
slvrsplsh
Offline
Joined: 2011-11-01
Points: 0

Hi All,

Thanks for letting me be a member of this Forum.

I am having a problem installing Java. I have tried several files, but I keep getting an error: "Permission Denied". I have a Lenovo ThinkPad T-42, running LinuxMint 11 (Ubuntu derivative). My current JDK is 6.0. I have Eclipse (Galileo) installed. and am trying to install JDK 7 with NetBeans 7.0.1. I have tried installing the files as User, Root, and as SUDO...No luck. I tried to make sure the files are executable. They are not. When I try to manually set them to executable, they default back to non-executable.

Can Someone give a hint to get me started?

Thanks!

Reply viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Rocco_Casaburo
Offline
Joined: 2011-03-17
Points: 0

Hi slvrsplsh,

first of all: I think that you should post this question on a Linux community forum...

second: please be sure that every file you need to execute is located in the "right" filesystem.

Usually, if the file is on FAT32 or NTFS filesystem (for example, a Windows partition) you are not allowed to set it as executable, even if you operate as root: it's a filesystem limit /security implementation.

Trying to copy files into your home folder or desktop, then setting it as executable, may solve the issue.