Skip to main content

Blog Archive for hofsass during August 2007

When using WSIT with JDK6 (initial release and updates 1 and 2), there are conflicting versions of the JAX-WS APIs. Specifically, JDK6 ships with JAX-WS 2.0 APIs and WSIT ships with JAX-WS 2.1 APIs. To get around this problem, it is necessary to copy the WSIT 'webservices-api.jar' file to $JAVA_HOME/lib/endorsed. This will ensure that the JVM loads the JAX-WS 2.1 APIs rather than its original...
Previously WSIT didn't support installing to Tomcat 6. A problem mainly caused by a directory, shared/lib, that is no longer part of the default Tomcat install image. A manual workaround for this was described by Arun Gupta in one of his blog entries, here. However, the WSIT install script for Tomcat has now been updated and will handle both Tomcat 5.5 and Tomcat 6. There were two related issues...